Building WxWidgets in Ubuntu Topic is solved

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
Double Trouble
Knows some wx things
Knows some wx things
Posts: 26
Joined: Sat Jun 14, 2008 12:42 pm
Location: Sweden
Contact:

Building WxWidgets in Ubuntu

Post by Double Trouble » Sun Jun 22, 2008 5:00 pm

Hi!
I'm quite new to WxWidgets and also to Linux but I'm trying to set up wxWidgets on my laptop with Ubuntu Hardy Heron.

So I'm reading this tutorial:

http://wiki.wxwidgets.org/Compiling_and_getting_started

But I got stuck here:
You will also need gtk+ (don't forget to install the -dev package if your distro uses them)

It is recommended to use at least GTK+ 2.2.3, and some features are only available when using more recent version, like GTK+ 2.8.
When I search for gtk+ I get so many different alternatives I don't know which one to pick. I use aptitude,

sudo aptitude search gtk+

Can I get some guidance? :)

Thank you in advance!

Jorg
Moderator
Moderator
Posts: 3971
Joined: Fri Aug 27, 2004 9:38 pm
Location: Delft, Netherlands
Contact:

Post by Jorg » Sun Jun 22, 2008 5:35 pm

First off, are you sure you want to recompile wxWidgets ? Ubuntu has the packages you need to develop wxWidgets in the synapic repository, which also makes it easier to distribute your binaries. The whole idea of packages is that if wxWidgets gets updated by the devs your application automatically benefits from the updates. Linking statically is usually not a good idea.

- Jorgen
Forensic Software Engineer
Netherlands Forensic Insitute
http://english.forensischinstituut.nl/
-------------------------------------
Jorg's WasteBucket
http://www.xs4all.nl/~jorgb/wb

DavidHart
Site Admin
Site Admin
Posts: 3894
Joined: Thu Jan 12, 2006 6:23 pm
Location: IoW, UK

Post by DavidHart » Sun Jun 22, 2008 5:37 pm

Hi,

The hardy gtk package is libgtk2.0-0, which (unless you've done something unusual to your system) is 2.12. That will probably already be installed; however you'll need the corresponding devel package, libgtk2.0-dev.

You'll need build-essential too, unless you've installed its components separately.

Regards,

David

Double Trouble
Knows some wx things
Knows some wx things
Posts: 26
Joined: Sat Jun 14, 2008 12:42 pm
Location: Sweden
Contact:

Post by Double Trouble » Sun Jun 22, 2008 9:38 pm

Jorg wrote:First off, are you sure you want to recompile wxWidgets ? Ubuntu has the packages you need to develop wxWidgets in the synapic repository, which also makes it easier to distribute your binaries. The whole idea of packages is that if wxWidgets gets updated by the devs your application automatically benefits from the updates. Linking statically is usually not a good idea.

- Jorgen
Ah!
That seems a lot easier!
Which package should I get from Synaptic? My guess is libwxgtk2.8-dev but I'm not confident enough! :oops:

Thank you in advance!

Auria
Site Admin
Site Admin
Posts: 6695
Joined: Thu Sep 28, 2006 12:23 am
Contact:

Post by Auria » Sun Jun 22, 2008 11:57 pm

Yes that's the one

Double Trouble
Knows some wx things
Knows some wx things
Posts: 26
Joined: Sat Jun 14, 2008 12:42 pm
Location: Sweden
Contact:

Post by Double Trouble » Mon Jun 23, 2008 5:51 pm

Auria wrote:Yes that's the one
Thanks!

Post Reply