Help request on Windows-OpenGL sample error massage. Topic is solved

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
Modeller
In need of some credit
In need of some credit
Posts: 5
Joined: Sun Jan 21, 2007 11:36 am

Help request on Windows-OpenGL sample error massage.

Post by Modeller » Mon Jan 22, 2007 9:02 pm

Hi there!

I am new to wxWidgets :oops:. After support from the forum participants, I managed to build the static libraries necessary to implement the code with wxWidgets :) . However, during the compilation of the samples, all of the OpenGL samples failed to compile. The warnings/errors for the sample Pinguin are as follows :

penguin : warning PRJ0041 : Cannot find missing dependency 'winwlm.h' for file 'penguin.rc'. Your project may still build, but may continue to appear out of date until this file is found.


The same warning for 'macwin32.h' (6 times!)
The same warning for 'rpcerr.h'
The same warning for 'rpcmac.h'
The same warning for 'macname1.h'
The same warning for 'macpub.h'
The same warning for 'macapi.h'
The same warning for 'macname2.h'
The same warning for 'aygshell.h'

Any idea why I get these warnings?

And

Compiling...
trackball.c
Compiling...
dxfrenderer.cpp
.\dxfrenderer.cpp(27) : fatal error C1189: #error : "OpenGL required: set wxUSE_GLCANVAS to 1 and rebuild the library"
penguin.cpp
.\penguin.cpp(24) : fatal error C1189: #error : "OpenGL required: set wxUSE_GLCANVAS to 1 and rebuild the library"
Generating Code...

Build log was saved at "file...." penguin - 2 error(s), 0 warning(s)

Unfortunately, I do not understand the error C1189 that repeats twice : "OpenGL required: set wxUSE_GLCANVAS to 1"

Any idea why I get these errors for OpenGL?

I appreciate any comment/help/recommendation/link :roll: .

Regards
M.

System Information : XP Proffessional, Visual C++ Express Edition

Auria
Site Admin
Site Admin
Posts: 6695
Joined: Thu Sep 28, 2006 12:23 am
Contact:

Post by Auria » Wed Jan 24, 2007 12:22 am

#error : "OpenGL required: set wxUSE_GLCANVAS to 1 and rebuild the library"
I have never used wx on windows so i cannot answer precisely, but on mac and linux you needed to compile with the --with-opengl option to enable opengl, otherwise you got a similar error message. Did you enable opengl?

Modeller
In need of some credit
In need of some credit
Posts: 5
Joined: Sun Jan 21, 2007 11:36 am

Post by Modeller » Sun Jan 28, 2007 12:34 pm

Auria,

I thank you very much for your reply. Enabling Open-GL has never been occurred to me since this is a sample which is supposed to work upon compilation. I did not check yet but I am sure that this is the probable cause. Sorry that I am late for answering your post. :oops:

Regards, :)
M.

Post Reply