is gtk 1.2.10 newer than 1.2.3?

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
snowsquirrel
Earned a small fee
Earned a small fee
Posts: 19
Joined: Thu Dec 30, 2004 11:37 pm

is gtk 1.2.10 newer than 1.2.3?

Post by snowsquirrel » Fri Jan 28, 2005 11:54 pm

configure fails like this:

Code: Select all

checking for GTK+ version... 
checking for pkg-config... no
checking for GTK+ - version >= 2.0.0... no
*** A new enough version of pkg-config was not found.
*** See http://pkgconfig.sourceforge.net
configure: error:
Please check that gtk-config is in path, the directory
where GTK+ libraries are installed (returned by
'gtk-config --libs' command) is in LD_LIBRARY_PATH or
equivalent variable and GTK+ is version 1.2.3 or above.
when I issue the command gtk-config --version I get 1.2.10. Isn't that newer than 1.2.3?

thanks,

~S

Linkku
Knows some wx things
Knows some wx things
Posts: 33
Joined: Sun Jan 02, 2005 5:16 pm

Re: is gtk 1.2.10 newer than 1.2.3?

Post by Linkku » Sat Jan 29, 2005 9:07 am

snowsquirrel wrote:configure fails like this:

Code: Select all

checking for GTK+ version... 
checking for pkg-config... no
checking for GTK+ - version >= 2.0.0... no
*** A new enough version of pkg-config was not found.
*** See http://pkgconfig.sourceforge.net
configure: error:
Please check that gtk-config is in path, the directory
where GTK+ libraries are installed (returned by
'gtk-config --libs' command) is in LD_LIBRARY_PATH or
equivalent variable and GTK+ is version 1.2.3 or above.
when I issue the command gtk-config --version I get 1.2.10. Isn't that newer than 1.2.3?

thanks,

~S
I had the same problem. Try "apt-get install libgtk2.0-dev". Yoy get development libraries for GTK2.

[edit]
Yoy maybe need libwxgtk2.5.3 too.
[edit2]
I have following packages installed:
dpkg -l | grep wx wrote: ii libwxbase2.4 2.4.2.6 wxBase library (runtime) - non-GUI support c
ii libwxgtk2.4 2.4.2.6 wxWindows Cross-platform C++ GUI toolkit (GT
ii libwxgtk2.4-py 2.4.2.6 wxWindows Cross-platform C++ GUI toolkit (wx
ii libwxgtk2.5.3 2.5.3.2 wxWidgets Cross-platform C++ GUI toolkit (GT
ii wx2.5-common 2.5.3.2 wxWidgets Cross-platform C++ GUI toolkit (co
ii wxwin2.4-heade 2.4.2.6 wxWindows Cross-platform C++ GUI toolkit (he
--- http://linkku.has.it ---

- Debian Etch, KDevelop3, Anjuta2, wxWidgets CVS, GCC 3.3
- Windows XP, wxDevCpp, wxWidgets 2.6.1

snowsquirrel
Earned a small fee
Earned a small fee
Posts: 19
Joined: Thu Dec 30, 2004 11:37 pm

Post by snowsquirrel » Mon Jan 31, 2005 3:40 pm

I was trying to build with gtk 1.2 as most of our machines here have it already installed.

We are in a Solaris environment, so apt-get is not really an option.
~S

snowsquirrel
Earned a small fee
Earned a small fee
Posts: 19
Joined: Thu Dec 30, 2004 11:37 pm

Post by snowsquirrel » Mon Jan 31, 2005 8:17 pm

Code: Select all

./configure --with-gtk --disable-gtk2
did the trick, though I don't really know why it is needed.

~S

Avi
Super wx Problem Solver
Super wx Problem Solver
Posts: 398
Joined: Mon Aug 30, 2004 9:27 pm
Location: Tel-Aviv, Israel

Post by Avi » Mon Jan 31, 2005 8:28 pm

Well, AFAIK, wxWidgets 2.5.3 defaults to using GTK2, so that is why you need to configure it to use gtk1.x.x... (someone correct me pls if I'm wrong)

snowsquirrel
Earned a small fee
Earned a small fee
Posts: 19
Joined: Thu Dec 30, 2004 11:37 pm

Post by snowsquirrel » Tue Feb 01, 2005 5:47 pm

Oh, I thought the point of a configure script was to detect what you had.
~S

leio
Can't get richer than this
Can't get richer than this
Posts: 802
Joined: Mon Dec 27, 2004 10:46 am
Location: Estonia, Tallinn
Contact:

Post by leio » Tue Feb 01, 2005 9:45 pm

Ever since 2.5.3 it default to gtk+-2.x.
Before that you had to do --enable-gtk2 to get it to work with gtk2, not gtk1. Now you have to do --disable-gtk2 to get it to be using gtk1.
I highly suggest using gtk2, even under 2.5.3, just requires a --enable-gtk2 then.
gtk-config is for gtk1, these days packages use pkg-config.
For example you can find out your gtk2 version with

Code: Select all

pkg-config --modversion gtk+-2.0
snowsquirrel wrote:*** A new enough version of pkg-config was not found.
*** See http://pkgconfig.sourceforge.net
Seems you don't have a new enough pkg-config, and I suspect you don't have the dev packages of gtk+-2.x either so that you could build wxGTK yourself and not get it from the package of your distribution.
Compilers: gcc-3.3.6, gcc-3.4.5, gcc-4.0.2, gcc-4.1.0 and MSVC6
OS's: Gentoo Linux, WinXP; WX: CVS HEAD

Project Manager of wxMUD - http://wxmud.sf.net/
Developer of wxGTK;
gtk+ port maintainer of OMGUI - http://www.omgui.org/

Post Reply