Can't build 2.5.3, ./include/wx/motif dir is missing.

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
snowsquirrel
Earned a small fee
Earned a small fee
Posts: 19
Joined: Thu Dec 30, 2004 11:37 pm

Can't build 2.5.3, ./include/wx/motif dir is missing.

Post by snowsquirrel » Thu Jan 06, 2005 11:07 pm

I am builing wxWidgets on Solaris 9, gcc 3.2.2.

Code: Select all

My configure seems to go ok, but the build craps out with the following error:
./bk-deps g++ -c -o coredll_event.o  -D__WXMOTIF__   -I./src/jpeg     -I./src/expat/lib -DWXUSINGDLL -DWXMAKINGDLL_CORE -DwxUSE_BASE=0 -fPIC -DPIC -Ilib/wx/include/motif-ansi-release-2.5 -I./include -I/usr/openwin/include -I/usr/dt/include -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -isystem /usr/openwin/include -O2 -pthreads -D_REENTRANT -Wall src/common/event.cpp
In file included from include/wx/event.h:32,
                 from include/wx/app.h:20,
                 from src/common/event.cpp:40:
include/wx/cursor.h:7:29: wx/motif/cursor.h: No such file or directory
In file included from include/wx/event.h:32,
                 from include/wx/app.h:20,
                 from src/common/event.cpp:40:
include/wx/cursor.h: In destructor 
   `wxBusyCursorSuspender::~wxBusyCursorSuspender()':
include/wx/cursor.h:55: invalid use of undefined type `const struct wxCursor'
include/wx/gdicmn.h:36: forward declaration of `const struct wxCursor'
In file included from include/wx/app.h:20,
                 from src/common/event.cpp:40:
include/wx/event.h: At global scope:
include/wx/event.h:861: field `m_cursor' has incomplete type
include/wx/event.h: In constructor `wxSetCursorEvent::wxSetCursorEvent(int, 
   int)':
include/wx/event.h:840: class `wxSetCursorEvent' does not have any field named 
   `m_cursor'
include/wx/event.h: In copy constructor 
   `wxSetCursorEvent::wxSetCursorEvent(const wxSetCursorEvent&)':
include/wx/event.h:847: `class wxSetCursorEvent' has no member named `m_cursor'
include/wx/event.h:847: class `wxSetCursorEvent' does not have any field named 
   `m_cursor'
include/wx/event.h: In member function `void wxSetCursorEvent::SetCursor(const 
   wxCursor&)':
include/wx/event.h:853: `m_cursor' undeclared (first use this function)
include/wx/event.h:853: (Each undeclared identifier is reported only once for 
   each function it appears in.)
In file included from include/wx/font.h:25,
                 from include/wx/window.h:28,
                 from include/wx/app.h:23,
                 from src/common/event.cpp:40:

[b]!!! SNIP !!![/b]

wxDCBase::FloodFill(int, int, const 
   wxColour&, int)':
include/wx/dc.h:156: `DoFloodFill' undeclared (first use this function)
include/wx/dc.h: In member function `bool wxDCBase::GetPixel(int, int, 
   wxColour*) const':
include/wx/dc.h:162: `DoGetPixel' undeclared (first use this function)
include/wx/dc.h: In member function `void wxDCBase::DrawLine(int, int, int, 
   int)':
include/wx/dc.h:167: `DoDrawLine' undeclared (first use this function)
include/wx/dc.h: In member function `void wxDCBase::CrossHair(int, int)':
include/wx/dc.h:172: `DoCrossHair' 
Last edited by snowsquirrel on Fri Jan 07, 2005 5:41 pm, edited 1 time in total.

Jorg
Moderator
Moderator
Posts: 3971
Joined: Fri Aug 27, 2004 9:38 pm
Location: Delft, Netherlands
Contact:

Post by Jorg » Fri Jan 07, 2005 7:51 am

Please try to keep it brief. After 5+ warnings people do not bother to look at the other 80. Usually the warnings are inter-related and solving the top most, solves all.

- Jorgen
Forensic Software Engineer
Netherlands Forensic Insitute
http://english.forensischinstituut.nl/
-------------------------------------
Jorg's WasteBucket
http://www.xs4all.nl/~jorgb/wb

snowsquirrel
Earned a small fee
Earned a small fee
Posts: 19
Joined: Thu Dec 30, 2004 11:37 pm

Post by snowsquirrel » Fri Jan 07, 2005 5:43 pm

What I get from the message is that the directory wx/motif/ does not exist.

I am not sure if I this is a bug, or if am interpreting incorrectly.

~S#include "wx/wxprec.h" not like

Jorg
Moderator
Moderator
Posts: 3971
Joined: Fri Aug 27, 2004 9:38 pm
Location: Delft, Netherlands
Contact:

Post by Jorg » Fri Jan 07, 2005 6:49 pm

As I might not know the answer for Solaris builds, please repeat all the steps here you did from d/l till build. People who are familiar with the config, might be able to tell you what step you missed ...

- Jorgen
Forensic Software Engineer
Netherlands Forensic Insitute
http://english.forensischinstituut.nl/
-------------------------------------
Jorg's WasteBucket
http://www.xs4all.nl/~jorgb/wb

snowsquirrel
Earned a small fee
Earned a small fee
Posts: 19
Joined: Thu Dec 30, 2004 11:37 pm

Post by snowsquirrel » Fri Jan 07, 2005 6:55 pm

1. download
2. unpack
3. cd wx*
4. ./configure
5. gmake[/list]

User avatar
ABX
Can't get richer than this
Can't get richer than this
Posts: 810
Joined: Mon Sep 06, 2004 1:43 pm
Location: Poznan, Poland
Contact:

Post by ABX » Fri Jan 07, 2005 7:00 pm

snowsquirrel wrote:1. download
What was the name of the downloaded file? Did you verified include/wx/motif is there or not?

ABX
CVS Head, 2.8.X
wxMSW, wxWinCE, wxPalmOS, wxOS2, wxMGL, bakefile
gcc 3.2.3, bcc 5.51, dmc 8.48, ow 1.6, vc 7.1, evc 3/4, pods 1.2

snowsquirrel
Earned a small fee
Earned a small fee
Posts: 19
Joined: Thu Dec 30, 2004 11:37 pm

Post by snowsquirrel » Fri Jan 07, 2005 8:03 pm

I donloaded the wxX11 package. The INSTALL.TXT said that moftif is included in that package. It was wrong. I downloaded the wxMotif package, and am compiling right now. I suspect that I will get further this time.

~S

Post Reply