link error, from a new wxWidgets user. thanks

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
Vanderbilt
In need of some credit
In need of some credit
Posts: 3
Joined: Thu Apr 13, 2006 2:26 pm

link error, from a new wxWidgets user. thanks

Post by Vanderbilt » Thu Apr 13, 2006 2:50 pm

Hi,

I am a new user of wxWidgets 2.6.3. And I am building a source code I just downloaded, which uses wxWidgets. It compiles, but doesn't link.

I have got over 200 errors like this:
EDISON error LNK2001: unresolved external symbol "protected: virtual class wxEventHashTable & __thiscall wxHtmlWindow::GetEventHashTable(void)const " ([email protected][email protected]@[email protected]@XZ)
EDISON error LNK2001: unresolved external symbol "protected: virtual struct wxEventTable const * __thiscall wxHtmlWindow::GetEventTable(void)const " ([email protected]@@[email protected]@XZ)
EDISON error LNK2001: unresolved external symbol "protected: virtual void __thiscall wxHtmlWindow::OnInternalIdle(void)" ([email protected]@@MAEXXZ)
EDISON error LNK2001: unresolved external symbol "public: virtual bool __thiscall wxHtmlFilterPlainText::CanRead(class wxFSFile const &)const " ([email protected]@@[email protected]@@Z)
EDISON error LNK2001: unresolved external symbol "public: virtual class wxClassInfo * __thiscall wxHtmlFilter::GetClassInfo(void)const " ([email protected]@@[email protected]@XZ)
EDISON error LNK2001: unresolved external symbol "public: virtual class wxClassInfo * __thiscall wxHtmlFilterPlainText::GetClassInfo(void)const " ([email protected]@@[email protected]@XZ)
EDISON error LNK2001: unresolved external symbol "public: virtual class wxClassInfo * __thiscall wxHtmlWindow::GetClassInfo(void)const " ([email protected]@@[email protected]@XZ)

Is it that I have libraries missing in my local library? what are they?

thanks

Vanderbilt

Ksmith22
I live to help wx-kind
I live to help wx-kind
Posts: 199
Joined: Mon Nov 21, 2005 4:34 pm

Post by Ksmith22 » Thu Apr 13, 2006 3:12 pm

Are you linking with wx*_html.lib? (where * is whatever your platform/version is)

Vanderbilt
In need of some credit
In need of some credit
Posts: 3
Joined: Thu Apr 13, 2006 2:26 pm

good suggestion!

Post by Vanderbilt » Thu Apr 13, 2006 3:41 pm

Ksmith22 wrote:Are you linking with wx*_html.lib? (where * is whatever your platform/version is)
it links after I added wx**html.lib dependency.

thanks Ksmith22,

Post Reply