My wxWidgets application doesn't run in other computers,why? Topic is solved

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
idhan
Experienced Solver
Experienced Solver
Posts: 88
Joined: Tue Feb 28, 2006 9:03 pm

My wxWidgets application doesn't run in other computers,why?

Post by idhan » Sun Mar 19, 2006 8:16 pm

Hi..

I have created successful an wxWidgets application using Microsoft Visual Studio 2005 but when trying to run my .exe in another computer appears the message:

"The applicaci
Last edited by idhan on Sun Mar 19, 2006 8:50 pm, edited 1 time in total.

protocol
Moderator
Moderator
Posts: 680
Joined: Wed Jan 18, 2006 6:13 pm
Location: Dallas, TX
Contact:

Post by protocol » Sun Mar 19, 2006 8:48 pm

One thing is to make sure you link the libraries statically.
/* UIKit && wxWidgets 2.8 && Cocoa && .Net */
QuRegExmm
wxPCRE & ObjPCRE - Regex It!

idhan
Experienced Solver
Experienced Solver
Posts: 88
Joined: Tue Feb 28, 2006 9:03 pm

Post by idhan » Sun Mar 19, 2006 9:08 pm

can you explain to me more please? :lol:

protocol
Moderator
Moderator
Posts: 680
Joined: Wed Jan 18, 2006 6:13 pm
Location: Dallas, TX
Contact:

Post by protocol » Sun Mar 19, 2006 9:20 pm

When you compile an application you can link the libraries you are programming against (wxBase, etc) either statically or dynamically.

If you like the compiled code dynamically the end user will need to have the libraries on the computer you are using your app on (so that the app can link to the code).

But if you compile it statically then the libraries are embedded inside of the assembly. The only drawback is the output size. Depending on how many different libraries you are using the size can be huge, but it usually is not big.

Static builds, you do not need extrernal files, just the exe is enough.

Dynamic builds, you will need the libraries within the exe's path.

configure wxWidgets with: ./configure --disable-shared
/* UIKit && wxWidgets 2.8 && Cocoa && .Net */
QuRegExmm
wxPCRE & ObjPCRE - Regex It!

idhan
Experienced Solver
Experienced Solver
Posts: 88
Joined: Tue Feb 28, 2006 9:03 pm

Post by idhan » Sun Mar 19, 2006 9:52 pm

Hi :),

I understand the static and dynamic libraries, nevertheless, I spoke to
do it under vc++ 2005. Bacause "./configure --diseable-shared" works under linux and mac. But I didn't find any flag under "setup.h" for wxwidgets 6.2 under windows to compile it again for static library.

Do you know how can I do that under windows?

protocol
Moderator
Moderator
Posts: 680
Joined: Wed Jan 18, 2006 6:13 pm
Location: Dallas, TX
Contact:

Post by protocol » Sun Mar 19, 2006 10:41 pm

/* UIKit && wxWidgets 2.8 && Cocoa && .Net */
QuRegExmm
wxPCRE & ObjPCRE - Regex It!

idhan
Experienced Solver
Experienced Solver
Posts: 88
Joined: Tue Feb 28, 2006 9:03 pm

Post by idhan » Mon Mar 20, 2006 12:47 am

I am using MICROSOFT VISUAL STUDIO 2005 and I compile wxWidgets using this IDE. :wink:

emarti
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 210
Joined: Sat May 07, 2005 8:24 pm
Location: Eskisehir, TURKEY
Contact:

Post by emarti » Mon Mar 20, 2006 2:10 am

Hi,
I am using wxVCExpressIntegration to build my project. (has auto-configuration)

You must search for wxVCExpressIntegration this site.

Generally, it is problem that forget msvcrt8.dll.
- T U R K E Y ?
- I love this country!

WebSites:
http://mebt.sourceforge.net/
http://wxquran.sourceforge.net/

emarti
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 210
Joined: Sat May 07, 2005 8:24 pm
Location: Eskisehir, TURKEY
Contact:

Post by emarti » Mon Mar 20, 2006 2:13 am

- T U R K E Y ?
- I love this country!

WebSites:
http://mebt.sourceforge.net/
http://wxquran.sourceforge.net/

idhan
Experienced Solver
Experienced Solver
Posts: 88
Joined: Tue Feb 28, 2006 9:03 pm

Post by idhan » Mon Mar 20, 2006 8:33 am

didn't works because I am using microsoft visual studio 2005 profesional... :(

emarti
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 210
Joined: Sat May 07, 2005 8:24 pm
Location: Eskisehir, TURKEY
Contact:

Post by emarti » Mon Mar 20, 2006 9:23 pm

Ok, You are using MVS 2005. Make sure you link the libraries statically. Please, Build Library statically with using "nmake" again. Edit "config.vc"
in wxwidgets/build/msw folder.
- T U R K E Y ?
- I love this country!

WebSites:
http://mebt.sourceforge.net/
http://wxquran.sourceforge.net/

idhan
Experienced Solver
Experienced Solver
Posts: 88
Joined: Tue Feb 28, 2006 9:03 pm

Post by idhan » Mon Mar 20, 2006 10:46 pm

Upcase help me to solve the problem..

I have change the compilation option from "Multithread DLL" to "Multithread" for the "Realse" and "Debug" version of wxWidgets and I get perfect compilations using static libraries...

Thanks for all the comments.... :D

Post Reply