problems compile wx-2.6.2 on windows xp with cygwin/mingw

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
michkevin
In need of some credit
In need of some credit
Posts: 2
Joined: Mon Feb 13, 2006 10:52 am
Location: Cameroun

problems compile wx-2.6.2 on windows xp with cygwin/mingw

Post by michkevin » Mon Feb 13, 2006 1:07 pm

Hi All :oops:

I have succefully installed cygwin/Mingw-3.1.0 on windows xp Os I have downloaded and installed wxmsw-2.6.2 setup.exe
while running the "make" command for compilation, it faild with this mesage error:
make:*** [.pch/wxprec_coredll/wx/wxprec.h.gch] error 1 Ido not understand what is it due of.
please what could I do in this case?

king regards



[/url][/list][/list][/code][/quote][/u][/i][/b]
mike

chenzhengxi
Earned a small fee
Earned a small fee
Posts: 22
Joined: Tue Jan 17, 2006 9:49 am

Re: problems compile wx-2.6.2 on windows xp with cygwin/ming

Post by chenzhengxi » Mon Feb 13, 2006 10:33 pm

gcc does not support preprogress
update your mingw and then try

Zseka
In need of some credit
In need of some credit
Posts: 5
Joined: Sat Feb 11, 2006 4:04 pm

Post by Zseka » Wed Feb 15, 2006 6:58 pm

Hello.
You could check that your MINGDIR and PATH variable is correct.
If you are using MSYS you should type ./configure in the shell.
The precompiled headers are working with Code::Blocks. The problem lies somewhere else. Please post all the details how did you set up the devel enviroment, I will try to help. But the easiest thing would be to get a precompiled DevPak, or to use Wx-devcpp or Code::Blocks .Wx-Devcpp has all the stuff to start the project, in Code::Blocks there is a plugin that can install DevPaks.

Zseka

michkevin
In need of some credit
In need of some credit
Posts: 2
Joined: Mon Feb 13, 2006 10:52 am
Location: Cameroun

Post by michkevin » Thu Feb 16, 2006 11:25 am

Thank for your help
my main objectif was the installation of [color=blue]WXHASKELL[/color]
on [size=18][color=violet]windows xp os[/color][/size]
So from the Net I was awared it was necessary to first intall [color=blue]Cywin[/color], followed by [color=blue]Wxwidgets[/color], which itself need Mingwx.
from this, installation of [color=blue]cygwin and Mingwx [/color]end succeffully.
the main problem occur at running the [color=green]make[/color] command compiling [color=blue]Wxwidgets-2.6.2[/color]
I'll try what you have sugested and notifie you about the result.

King regards
mike

Post Reply