Page 1 of 1

gcc segmentation fault while compiling

Posted: Fri Feb 03, 2006 2:30 pm
by feua
Hi all

I'm trying to install wx on my winxp with cygwin. I've downloaded the wx package for windows, run the configure with the appropiate flag and all seems ok. At compile step I reach this error:

Code: Select all

../src/tiff/tif_zip.c
rm -f lib/libwxtiffd-2.6.a
ar rcu lib/libwxtiffd-2.6.a wxtiff_tif_win32.o wxtiff_tif_aux.o wxtiff_tif_close
.o wxtiff_tif_codec.o wxtiff_tif_color.o wxtiff_tif_compress.o wxtiff_tif_dir.o
wxtiff_tif_dirinfo.o wxtiff_tif_dirread.o wxtiff_tif_dirwrite.o wxtiff_tif_dumpm
ode.o wxtiff_tif_error.o wxtiff_tif_extension.o wxtiff_tif_fax3.o wxtiff_tif_fax
3sm.o wxtiff_tif_getimage.o wxtiff_tif_jpeg.o wxtiff_tif_flush.o wxtiff_tif_lzw.
o wxtiff_tif_luv.o wxtiff_tif_next.o wxtiff_tif_open.o wxtiff_tif_packbits.o wxt
iff_tif_pixarlog.o wxtiff_tif_predict.o wxtiff_tif_print.o wxtiff_tif_read.o wxt
iff_tif_swab.o wxtiff_tif_strip.o wxtiff_tif_thunder.o wxtiff_tif_tile.o wxtiff_
tif_version.o wxtiff_tif_warning.o wxtiff_tif_write.o wxtiff_tif_zip.o
ranlib lib/libwxtiffd-2.6.a
./bk-make-pch .pch/wxprec_baselib/wx/wxprec.h.gch wx/wxprec.h g++ -I.pch/wxprec_
baselib -D__WXMSW__     -I../src/tiff -I../src/jpeg -I../src/png     -DwxUSE_GUI
=0 -DwxUSE_BASE=1 -DWX_PRECOMP -DNO_GCC_PRAGMA -D__WXDEBUG__ -Ilib/wx/include/ms
w-ansi-debug-static-2.6 -I../include -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -ggdb
 -O0 -Wall -Wundef -Wno-ctor-dtor-privacy
../include/wx/wxprec.h:55: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
make: *** [.pch/wxprec_baselib/wx/wxprec.h.gch] Error 1

[email protected]_portatile ~/wxWidgets-2.6.2/build2
$
What can i do?

Thanks for help

Posted: Sun Feb 05, 2006 11:48 am
by chris
Hi feua,

internal compiler errors are a bug the compiler (cygwin), so technically it's not a wx problem. If possible you should try to update the compiler to a newer version.
However, if this is not possible:
The ICE seems to occur with precompiling the headers. You should be able to turn off those thru applying "--disable-precomp-headers" to configure. Maybe it works then.

HTH, Chris