linking problem with chinook IDE

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
Raghu
Experienced Solver
Experienced Solver
Posts: 79
Joined: Wed Oct 19, 2005 11:33 am

linking problem with chinook IDE

Post by Raghu » Thu Nov 03, 2005 12:18 pm

I'm facing problem linking wxwidgets program with static library in linux

I had created a library libstack.a, I had included the header files in the current project itself and placed libstack.a in standard directory $CDS\library\gcc\wxwidgets\lib. I had made the changes in build. I had specified the name "stack" in the library. It works fine with the windows setup. I did the same for linux, but not able to link with the functions of the library. What's the reason?

I had used "ar" command for creating .a lib, bcoz chinook doesn't provide creating the static lib.

cg
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 201
Joined: Sun Aug 29, 2004 12:33 am
Location: Canada
Contact:

Post by cg » Fri Nov 04, 2005 3:46 pm

Best place for help with Chinook is the Chinook forums:

http://www.degarrah.com/forums

HTH

Chris

------------------------------------------------------------
Chinook Developer Studio
*Free multiplatform IDE for BSD.Linux.Solaris.Windows*
http://www.degarrah.com/products/chinook/index.php

Zephyr Automated Test Runner
*Cross platform automated functional and regression testing*
http://www.degarrah.com/products/zephyr/index.php
------------------------------------------------------------

Post Reply