Failed compile on wxWidgets 3.1.4 using mingw.

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
oliverhbailey
In need of some credit
In need of some credit
Posts: 1
Joined: Wed Oct 21, 2020 4:16 pm

Failed compile on wxWidgets 3.1.4 using mingw.

Post by oliverhbailey » Wed Oct 21, 2020 4:41 pm

I cannot build a working DLL from source using the mingw compiler. With the config.gcc set to SHARED=1, MONOLITHIC=1, BUILD=RELEASE, and UNICODE=0, I receive an error in coreDLL_menuitem.o as follows: cannot convert LPLOGFONTW to LOGFONT. i have attached the console output on Windows 10 Home
Version 2004
Build 19041.450

Please advise.
Attachments
wxwidgets-3.1.4 build error.jpg

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 4529
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: Failed compile on wxWidgets 3.1.4 using mingw.

Post by ONEEYEMAN » Wed Oct 21, 2020 6:38 pm

Hi,
Please DO NOT modify the build file.
Use command line arguments to compile the library.

Also - is there a reason you want to use "MONOLITHIC=1 UNICODE=0"?
You will have many problems with 1st and 2nd is almost deprecated.

So please explain their usage.

Thank you.

PB
Part Of The Furniture
Part Of The Furniture
Posts: 2662
Joined: Sun Jan 03, 2010 5:45 pm

Re: Failed compile on wxWidgets 3.1.4 using mingw.

Post by PB » Wed Oct 21, 2020 7:19 pm

I confirm the issue is there both in 3.1.4 and the master.

ANSI build is basically deprecated but still supported, so I will create a ticket on wxTrac.

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 4529
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: Failed compile on wxWidgets 3.1.4 using mingw.

Post by ONEEYEMAN » Wed Oct 21, 2020 7:28 pm

PB,
Those option is very weird.
The last fixes for monolithic build was for CMake, right?

Thank you.

PB
Part Of The Furniture
Part Of The Furniture
Posts: 2662
Joined: Sun Jan 03, 2010 5:45 pm

Re: Failed compile on wxWidgets 3.1.4 using mingw.

Post by PB » Wed Oct 21, 2020 7:42 pm

ONEEYEMAN, MONOLITHIC=1 is supposed to work (well, at least in the master), its last fix was for STC sample in STATIC monolithic configuration.

I have created a ticket for the issue:
https://trac.wxwidgets.org/ticket/18949

EDIT
I have realized that this is not a wxWidgets issue but a bug in the MinGW headers, as I wrote in the ticket comment.

stahta01
Super wx Problem Solver
Super wx Problem Solver
Posts: 398
Joined: Fri Nov 03, 2006 2:00 pm

Re: Failed compile on wxWidgets 3.1.4 using mingw.

Post by stahta01 » Wed Oct 21, 2020 11:37 pm

What MinGW GCC are you using?

Edit: Based on your bug report it appears to be an 32 bit build of MinGW64 GCC. What GCC version?
Edit2: I am seeing if the problem is fixed like you suggest in MSys2 mingw-w64-headers-git package.
Edit3: It appears to not be fixed like your suggestion.

Tim S.

PB
Part Of The Furniture
Part Of The Furniture
Posts: 2662
Joined: Sun Jan 03, 2010 5:45 pm

Re: Failed compile on wxWidgets 3.1.4 using mingw.

Post by PB » Thu Oct 22, 2020 5:47 am

stahta01 wrote:
Wed Oct 21, 2020 11:37 pm
Based on your bug report ....
I have not suggested the issue is fixed. I posted that it is still present and included the link to the incorrect function declaration in mingw-w64 headers repo mirror.

stahta01
Super wx Problem Solver
Super wx Problem Solver
Posts: 398
Joined: Fri Nov 03, 2006 2:00 pm

Re: Failed compile on wxWidgets 3.1.4 using mingw.

Post by stahta01 » Fri Oct 23, 2020 2:46 am

PB wrote:
Thu Oct 22, 2020 5:47 am
stahta01 wrote:
Wed Oct 21, 2020 11:37 pm
Based on your bug report ....
I have not suggested the issue is fixed. I posted that it is still present and included the link to the incorrect function declaration in mingw-w64 headers repo mirror.
I did NOT say you said it was fixed; the first thing to do is always verified the problem has NOT been fixed!
Otherwise you waste a lot of time!

Tim S.

PB
Part Of The Furniture
Part Of The Furniture
Posts: 2662
Joined: Sun Jan 03, 2010 5:45 pm

Re: Failed compile on wxWidgets 3.1.4 using mingw.

Post by PB » Fri Oct 23, 2020 10:38 am

stahta01 wrote:
Fri Oct 23, 2020 2:46 am
I did NOT say you said it was fixed; the first thing to do is always verified the problem has NOT been fixed!
You did write
stahta01 wrote:
Wed Oct 21, 2020 11:37 pm
Edit2: I am seeing if the problem is fixed like you suggest in MSys2 mingw-w64-headers-git package.
Edit3: It appears to not be fixed like your suggestion.
Well, I am seeing that you wrote that I suggested the issue had been fixed in MSYS2 mingw-w64 headers package. I did not suggest anything like this, on the contrary: I posted a link to mingw-w64 headers repository (on which the MSYS2 package is based) mirror, showing the declaration is still incorrect there.

BTW, I do not think there is any need to shout.

stahta01
Super wx Problem Solver
Super wx Problem Solver
Posts: 398
Joined: Fri Nov 03, 2006 2:00 pm

Re: Failed compile on wxWidgets 3.1.4 using mingw.

Post by stahta01 » Fri Oct 23, 2020 12:19 pm

And, there is now no reason for me to help you!

Tim S.

PB
Part Of The Furniture
Part Of The Furniture
Posts: 2662
Joined: Sun Jan 03, 2010 5:45 pm

Re: Failed compile on wxWidgets 3.1.4 using mingw.

Post by PB » Fri Oct 23, 2020 1:07 pm

stahta01 wrote:
Fri Oct 23, 2020 12:19 pm
And, there is now no reason for me to help you!
You must have confused me with someone else: I do not remember ever asking for your help let alone being helped by you. Or perhaps you consider putting words in my mouth as "help"?

However, I may be wrong, my memory is not perfect.

stahta01
Super wx Problem Solver
Super wx Problem Solver
Posts: 398
Joined: Fri Nov 03, 2006 2:00 pm

Re: Failed compile on wxWidgets 3.1.4 using mingw.

Post by stahta01 » Fri Oct 23, 2020 2:44 pm

So, you plan to report the possible fix upstream to the MINGW64 people?

Tim S.

PB
Part Of The Furniture
Part Of The Furniture
Posts: 2662
Joined: Sun Jan 03, 2010 5:45 pm

Re: Failed compile on wxWidgets 3.1.4 using mingw.

Post by PB » Fri Oct 23, 2020 4:06 pm

I have just created a ticket:
https://sourceforge.net/p/mingw-w64/bugs/862/

Post Reply