Compiling wxWidgets 3.1.4 using nmake: libtiff error

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
In need of some credit
In need of some credit
Posts: 9
Joined: Fri Dec 06, 2019 1:10 pm

Compiling wxWidgets 3.1.4 using nmake: libtiff error

Post by smartmobili » Sun Oct 18, 2020 1:15 pm


I have to use some scripts developed internally to build a staged version of wxWidgets and this script use a build\mswbuild.bat with the following content:

@CALL "C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\VC\Auxiliary\Build\vcvarsall.bat" x86_amd64

but there is an error with libtiff:
d:\dev\tools\stage\source\wxwidgets\3.1.4\src\tiff\libtiff\tiffiop.h(31): fatal error C1083: Impossible d'ouvrir le fichier include : 'tif_config.h' : No such file or directory
How can I fix that ? Of course I can rename into tif_config.h and into tiffconf.h but is it not supposed to be done automatically ?

New Pagodi
Super wx Problem Solver
Super wx Problem Solver
Posts: 380
Joined: Tue Jun 20, 2006 6:47 pm

Re: Compiling wxWidgets 3.1.4 using nmake: libtiff error

Post by New Pagodi » Sun Oct 18, 2020 3:10 pm

Are you sure you need all that extra stuff? I just tried compiling the latest git version with

Code: Select all

nmake -f SHARED=0 BUILD=release TARGET_CPU=X64
and it worked just fine. I don't know what most of the extra you have does, but I know at least adding MP isn't going to do any good. nmake always compiles 1 file at a time and there is no way to make it do parallel builds. If you want to do parallel builds, you'll need to use msbuild or visual studio. Also the odbc package was unmaintained and removed several years ago. So `USE_ODBC=1` won't do anything either.

Post Reply