debugrpt sample problems Topic is solved

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
User avatar
Posts: 15655
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: debugrpt sample problems

Post by doublemax » Tue Jun 23, 2020 4:58 am

What happens if you just open the path to the php file in a browser? You should see an error message: "450 MD5 hash is missing."
Use the source, Luke!

Super wx Problem Solver
Super wx Problem Solver
Posts: 397
Joined: Thu Jun 01, 2006 4:36 pm
Location: Right here!

Re: debugrpt sample problems

Post by Widgets » Tue Jun 23, 2020 3:53 pm

That is exactly what happened, initially, but after some fiddling with the data supplied to MFCDemo, I finally got the server to accept the data :D
Thank you for sticking with this issue; it gave me enough information to keep trying with the original MFCDemo and now I can take on my 'real' application.
FWIW, the HTTP & SMPTP unit test still fail.
After a bit more digging, it looks like in my source code the project 'r' compiles the unit test code and fixing the HTTP URL to the same as that used in MFCDemo allows the UT for HTTP delivery work as expected.
No luck with updating the code for SMTP delivery and it still fails - & I won't take the time to chase that issue.
Environment: Win 10 64-bit & Mint 10.2
MSVC Express 2010, 2015, 2017, 2019
wxWidgets 3.1.2
Fight SPAM - report it with wxSR

Post Reply