[SOLVED] A boatload of errors

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
fmc
In need of some credit
In need of some credit
Posts: 5
Joined: Sun Dec 01, 2019 7:31 pm

[SOLVED] A boatload of errors

Post by fmc » Wed Dec 11, 2019 7:31 am

Code::Blocks: svn 11872
wxWidgets: 3.1.3 (compiled w/MinGW 8.1.0)

When I cranked up C::B, I tried to run the form it auto-creates, it gave a LOT of erros.

Please see them here

These are all coming from imagejpeg.cpp.

I obviously did something wrong. Can anyone tell me what that is?
Last edited by fmc on Thu Dec 12, 2019 8:38 pm, edited 1 time in total.

User avatar
doublemax
Moderator
Moderator
Posts: 14509
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: A boatload of errors

Post by doublemax » Wed Dec 11, 2019 5:39 pm

The libraries for tiff, jpeg are missing in the linker settings.

I don't know C:B too well, but this should help:
viewtopic.php?f=19&t=46125
Use the source, Luke!

fmc
In need of some credit
In need of some credit
Posts: 5
Joined: Sun Dec 01, 2019 7:31 pm

Re: A boatload of errors

Post by fmc » Thu Dec 12, 2019 6:18 pm

I read all four pages from that site, doublemax. No help. Any other ideas?

User avatar
doublemax
Moderator
Moderator
Posts: 14509
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: A boatload of errors

Post by doublemax » Thu Dec 12, 2019 6:49 pm

Check this: viewtopic.php?p=171359#p171359

A few posts down there is also a list of libraries that should be in the linker settings.
viewtopic.php?p=171363#p171363
Use the source, Luke!

fmc
In need of some credit
In need of some credit
Posts: 5
Joined: Sun Dec 01, 2019 7:31 pm

Re: A boatload of errors

Post by fmc » Thu Dec 12, 2019 8:38 pm

You're a good person, doublemax. I added all but one of the libraries and finally got a working GUI. Thanks a million! :D

Image

Image

Post Reply