wxWebView and Windows

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
User avatar
rocrail
I live to help wx-kind
I live to help wx-kind
Posts: 179
Joined: Fri Oct 02, 2009 2:02 pm
Contact:

Re: wxWebView and Windows

Post by rocrail » Thu Aug 01, 2019 7:46 am

OK, I did so.
But the popup still shows up...
Best regards,
Rob.

User avatar
rocrail
I live to help wx-kind
I live to help wx-kind
Posts: 179
Joined: Fri Oct 02, 2009 2:02 pm
Contact:

Re: wxWebView and Windows

Post by rocrail » Thu Aug 01, 2019 8:02 am

Here the error logging after I commented out the wxLogNull code line:

Code: Select all

10:00:12: Can't open registry key 'HKCU\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION' (error 2: Das System kann die angegebene Datei nicht finden.)
10:00:12: Can't set value of 'HKCU\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION\webview.exe' (error 2: Das System kann die angegebene Datei nicht finden.)
10:00:12: Failed to find web view emulation level in the registry
"Das System kann die angegebene Datei nicht finden" -> The system cannot find the specified file.
Best regards,
Rob.

User avatar
doublemax
Moderator
Moderator
Posts: 14083
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: wxWebView and Windows

Post by doublemax » Thu Aug 01, 2019 8:04 am

I meant use the code i posted instead of the other one.

If it's just for testing, you could also just set it by hand with regedit.
Use the source, Luke!

User avatar
rocrail
I live to help wx-kind
I live to help wx-kind
Posts: 179
Joined: Fri Oct 02, 2009 2:02 pm
Contact:

Re: wxWebView and Windows

Post by rocrail » Thu Aug 01, 2019 8:09 am

OK, commented it out, but the following error pops up:

Code: Select all

10:07:08: Can't open registry key 'HKCU\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION' (error 2: Das System kann die angegebene Datei nicht finden.)
10:07:08: Can't set value of 'HKCU\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION\webview.exe' (error 2: Das System kann die angegebene Datei nicht finden.)
Best regards,
Rob.

User avatar
doublemax
Moderator
Moderator
Posts: 14083
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: wxWebView and Windows

Post by doublemax » Thu Aug 01, 2019 8:15 am

Very strange. The "wxLogNull nolog;" should suppress these messages. Can you check in regedit if this path exists?
Use the source, Luke!

User avatar
rocrail
I live to help wx-kind
I live to help wx-kind
Posts: 179
Joined: Fri Oct 02, 2009 2:02 pm
Contact:

Re: wxWebView and Windows

Post by rocrail » Thu Aug 01, 2019 8:19 am

Hi,

the path does not exist in the registry.

In the log you see HKCU instead of HKEY_CURRENT_USER...
Best regards,
Rob.

User avatar
doublemax
Moderator
Moderator
Posts: 14083
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: wxWebView and Windows

Post by doublemax » Thu Aug 01, 2019 8:21 am

In the log you see HKCU instead of HKEY_CURRENT_USER...
That's ok, that's an official short-hand. But you can try with the long name.

Up to which entry does the path exist?
Use the source, Luke!

User avatar
rocrail
I live to help wx-kind
I live to help wx-kind
Posts: 179
Joined: Fri Oct 02, 2009 2:02 pm
Contact:

Re: wxWebView and Windows

Post by rocrail » Thu Aug 01, 2019 8:24 am

this part exists:

Code: Select all

HKCU\Software\Microsoft\Internet Explorer\Main
But should the rest of the path not be created by a function call first? (Create?)
Best regards,
Rob.

User avatar
rocrail
I live to help wx-kind
I live to help wx-kind
Posts: 179
Joined: Fri Oct 02, 2009 2:02 pm
Contact:

Re: wxWebView and Windows

Post by rocrail » Thu Aug 01, 2019 8:32 am

I add following line:

Code: Select all

#ifdef __WXMSW__
{
  wxLogNull nolog;   // suppress error messages
  wxRegKey rk( wxT("HKEY_CURRENT_USER\\Software\\Microsoft\\Internet Explorer\\Main\\FeatureControl\\FEATURE_BROWSER_EMULATION") );
  rk.Create();
  rk.SetValue( wxT("webview.exe"), 11001);
}
#endif
No error popups, but the mjpg format is still not supported.

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION]
"webview.exe"=dword:00002af9

BTW: Still testing with the wxWidgets webview sample.
Best regards,
Rob.

User avatar
doublemax
Moderator
Moderator
Posts: 14083
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: wxWebView and Windows

Post by doublemax » Thu Aug 01, 2019 8:45 am

Is the streaming link you're testing with public? If yes, can you post it?

There might be another option if you have a webserver that's under your control: Find a JavaScript video player that works with IE11, put it on your website with a script that takes an external URL. Then from your software, use that player and pass the URL for the stream.
Use the source, Luke!

User avatar
rocrail
I live to help wx-kind
I live to help wx-kind
Posts: 179
Joined: Fri Oct 02, 2009 2:02 pm
Contact:

Re: wxWebView and Windows

Post by rocrail » Thu Aug 01, 2019 8:50 am

The link is not public.

Edge under Windows 10 does support *.mjpg, so if webview.exe is told to emulate IE11 I would suspect it works with wxWebView too.
Should I open a Bug? wxWebView works out of the box under macOS and Linux-GTK.
Best regards,
Rob.

User avatar
doublemax
Moderator
Moderator
Posts: 14083
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: wxWebView and Windows

Post by doublemax » Thu Aug 01, 2019 8:53 am

wxWebView doesn't use Edge, only IE (which is still present on Windows 10). There is a webview implementation for Edge, but it was abandoned when Microsoft announced they'd switch to Chrome.

https://github.com/wxWidgets/wxWidgets/pull/807

There is also a Chromium backend, but it's a real pain to build it.
viewtopic.php?t=44661
Use the source, Luke!

User avatar
rocrail
I live to help wx-kind
I live to help wx-kind
Posts: 179
Joined: Fri Oct 02, 2009 2:02 pm
Contact:

Re: wxWebView and Windows

Post by rocrail » Thu Aug 01, 2019 1:09 pm

There seems to be work arounds for IE:
https://www.yawcam.com/forum/viewtopic.php?t=3592
But unfortunately this does not work. I also tested it directly with the MS InternetExplorer.
Best regards,
Rob.

User avatar
doublemax
Moderator
Moderator
Posts: 14083
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: wxWebView and Windows

Post by doublemax » Thu Aug 01, 2019 4:03 pm

Maybe you should reconsider wxVLC :)
Use the source, Luke!

User avatar
rocrail
I live to help wx-kind
I live to help wx-kind
Posts: 179
Joined: Fri Oct 02, 2009 2:02 pm
Contact:

Re: wxWebView and Windows

Post by rocrail » Thu Aug 01, 2019 5:26 pm

Splitting up the mjpg stream is very simple.
I will implement a small widget for this...
Best regards,
Rob.

Post Reply