Page 1 of 1

Build 32bit using tdm64-gcc-5.1.0-2

Posted: Fri Jul 19, 2019 11:59 am
by BobsTheDude
I am using tdm64-gcc-5.1.0-2, but can I build wxWidgets in 32bit using this version of tdm64-gcc-5.1.0-2, if so how? Or do I need to scrap this version and just use the 32bit version of tdm?

This is for Windows 10.

Thanks

Re: Build 32bit using tdm64-gcc-5.1.0-2

Posted: Sat Jul 20, 2019 2:43 pm
by doublemax
According to https://stackoverflow.com/questions/196 ... -mingw-w64 it should be possible by adding "-m32" or "-m64" to the compiler command line (set with CXXFLAGS) if the compiler is build as "multilib".

However, i tested with the MinGW from https://sourceforge.net/projects/mingw- ... -with-ada/ and didn't get it to work.

So maybe it's just easier to install the 32bit compiler if you only don't need to support 32 and 64bit.

Re: Build 32bit using tdm64-gcc-5.1.0-2

Posted: Sat Jul 20, 2019 4:45 pm
by BobsTheDude
Thanks doublemax, I just installed the 32-bit version and left the 64-bit in place in case I want to use in the future.