How to build wxWidgets-3.1.2 using MinGW-w64?

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
spflanze
Earned some good credits
Earned some good credits
Posts: 118
Joined: Tue Feb 15, 2011 10:02 pm

How to build wxWidgets-3.1.2 using MinGW-w64?

Post by spflanze » Fri May 24, 2019 4:42 am

I am attempting to compile wxWidgets-3.1.2 using MinGW-w64 in Windows 7. I downloaded and installed MinGW-w64 from:
https://sourceforge.net/projects/mingw-w64/
In the installation I set these values:
Version: 8.1.0
Architecture: x86_64
Threads: posix
Exception seh
Build revison: 0
I started up MinGW-w64 by using the Windows Explorer to execute the batch file: mingw-w64.bat in the directory:
\Program Files\mingw-w64\x86_64-8.1.0-posix-seh-rt_v6-rev0.

In the terminal emulator window that opened I executed this command sequence, and got these results:

Code: Select all

C:\>cd C:\wxWidgets-3.1.2\build\msw
C:\wxWidgets-3.1.2\build\msw>where mingw32-make.exe
C:\Program Files\mingw-w64\x86_64-8.1.0-posix-seh-rt_v6-rev0\mingw64\bin\mingw32
-make.exe
C:\wxWidgets-3.1.2\build\msw>mingw32-make.exe -f makefile.gcc MONOLITHIC=0 USE_X  RC=1 SHARED=1 UNICODE=1 USE_OPENGL=1 BUILD=release
mingw32-make.exe: *** No rule to make target 'USE_X'.  Stop.
What went wrong here? Why do I get this no rule error?

spflanze
Earned some good credits
Earned some good credits
Posts: 118
Joined: Tue Feb 15, 2011 10:02 pm

Re: How to build wxWidgets-3.1.2 using MinGW-w64?

Post by spflanze » Fri May 24, 2019 5:24 am

The error was due to "USE_X" in the make command line. It did compile after I removed it.

Post Reply