g++: error: c:/wxBuild/lib/libwx_mswu-3.1.a: No such file or directory

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
User avatar
TukingFypo
In need of some credit
In need of some credit
Posts: 8
Joined: Tue Jan 22, 2019 1:16 pm

g++: error: c:/wxBuild/lib/libwx_mswu-3.1.a: No such file or directory

Post by TukingFypo » Tue Jan 22, 2019 1:21 pm

File libwx_mswu-3.1.a does not exist ANYWHERE!!! - Any ideas??? (see below)

Thanks in advance!!!!


Win7 64bits / MinGW Compiler (v.6.3.0 - Target: mingw32)


Configure Command:
==================
../wxWidgets-3.1.2/configure --enable-optimise --enable-stl --enable-unicode --disable-threads --disable-shared --enable-monolithic


COMPILE settings (wx-config --cxxflags):
===================================
-I/c/wxBuild/lib/wx/include/msw-unicode-static-3.1 -I/c/wxWidgets-3.1.2/include -D_LARGEFILE_SOURCE=unknown -D__WXMSW__


BUILD settings (wx-config --libs):
============================
-L/c/wxBuild/lib -Wl,--subsystem,windows -mwindows #####>>>/c/wxBuild/lib/libwx_mswu-3.1.a<<<##### -lwxtiff-3.1 -lwxjpeg-3.1 -lwxpng-3.1 -lwxregexu-3.1 -lwxscintilla-3.1 -lwxexpat-3.1 -lwxzlib-3.1 -lrpcrt4 -loleaut32 -lole32 -luuid -luxtheme -lwinspool -lwinmm -lshell32 -lshlwapi -lcomctl32 -lcomdlg32 -ladvapi32 -lversion -lwsock32 -lgdi32 -loleacc


Error on Eclipse Console
=====================
15:13:33 **** Incremental Build of configuration Debug for project wx03 ****
Info: Internal Builder is used for build
g++ -owx03.exe main.o -L/c/wxBuild/lib -Wl,--subsystem,windows -mwindows c:/wxBuild/lib/libwx_mswu-3.1.a -lwxtiff-3.1 -lwxjpeg-3.1 -lwxpng-3.1 -lwxregexu-3.1 -lwxscintilla-3.1 -lwxexpat-3.1 -lwxzlib-3.1 -lrpcrt4 -loleaut32 -lole32 -luuid -luxtheme -lwinspool -lwinmm -lshell32 -lshlwapi -lcomctl32 -lcomdlg32 -ladvapi32 -lversion -lwsock32 -lgdi32 -loleacc
g++: error: c:/wxBuild/lib/libwx_mswu-3.1.a: No such file or directory

15:13:34 Build Finished. 0 errors, 0 warnings. (took 624ms)

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 3163
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: g++: error: c:/wxBuild/lib/libwx_mswu-3.1.a: No such file or directory

Post by ONEEYEMAN » Tue Jan 22, 2019 3:25 pm

Hi,
You should first build wxWidgets itself.
Please check the documentation/different posts here in the forums about how to properly build the library with you specific toolchain.

Thank you.

User avatar
TukingFypo
In need of some credit
In need of some credit
Posts: 8
Joined: Tue Jan 22, 2019 1:16 pm

Re: g++: error: c:/wxBuild/lib/libwx_mswu-3.1.a: No such file or directory

Post by TukingFypo » Tue Jan 22, 2019 3:45 pm

Hi,
I did that.
After the configure command I ran make.
Thanks!!!

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 3163
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: g++: error: c:/wxBuild/lib/libwx_mswu-3.1.a: No such file or directory

Post by ONEEYEMAN » Tue Jan 22, 2019 3:56 pm

Hi,
Was there any errors?
Also, what compiler did you use and what environment?

Thank you.

User avatar
TukingFypo
In need of some credit
In need of some credit
Posts: 8
Joined: Tue Jan 22, 2019 1:16 pm

Re: g++: error: c:/wxBuild/lib/libwx_mswu-3.1.a: No such file or directory

Post by TukingFypo » Tue Jan 22, 2019 5:10 pm

I did not redirected the make output to a file, but as far as I saw, no errors.

Win7 64bits / MinGW Compiler (v.6.3.0 - Target: mingw32)

Thanks!!!

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 3163
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: g++: error: c:/wxBuild/lib/libwx_mswu-3.1.a: No such file or directory

Post by ONEEYEMAN » Tue Jan 22, 2019 5:20 pm

Hi,
Do you use CygWin by chance?
Using MinGW to compile wxWidgets does not require running configure. In fact it is wrong.
Did you read the documentation?

Thank you.

User avatar
TukingFypo
In need of some credit
In need of some credit
Posts: 8
Joined: Tue Jan 22, 2019 1:16 pm

Re: g++: error: c:/wxBuild/lib/libwx_mswu-3.1.a: No such file or directory

Post by TukingFypo » Tue Jan 22, 2019 5:40 pm

No. I don't use CygWin.
No need to run configure??? I'll double check the procedure and let you know.

Thanks again!!!

stahta01
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 246
Joined: Fri Nov 03, 2006 2:00 pm

Re: g++: error: c:/wxBuild/lib/libwx_mswu-3.1.a: No such file or directory

Post by stahta01 » Tue Jan 22, 2019 5:42 pm

Does linking to "wx_mswu-3.1" without the quotes work?

Tim S.

stahta01
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 246
Joined: Fri Nov 03, 2006 2:00 pm

Re: g++: error: c:/wxBuild/lib/libwx_mswu-3.1.a: No such file or directory

Post by stahta01 » Tue Jan 22, 2019 5:45 pm

TukingFypo wrote:No. I don't use CygWin.
No need to run configure??? I'll double check the procedure and let you know.

Thanks again!!!
If you did not use CygWin, MSys2, or MSys? Then the configure should not have worked without the use of an Unix like environment.

Are you using a Unix like environment; if yes, which one?

Tim S.

User avatar
TukingFypo
In need of some credit
In need of some credit
Posts: 8
Joined: Tue Jan 22, 2019 1:16 pm

Re: g++: error: c:/wxBuild/lib/libwx_mswu-3.1.a: No such file or directory

Post by TukingFypo » Wed Jan 23, 2019 10:39 am

Hi, Tim.

I used msys on Win7.

Thanks!!!

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 3163
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: g++: error: c:/wxBuild/lib/libwx_mswu-3.1.a: No such file or directory

Post by ONEEYEMAN » Wed Jan 23, 2019 1:21 pm

Hi,
Are your trying to build your software from Msys?
Did you look for the library inside the appropriate directory?
Are other libraries from wx build present?

Thank you.

stahta01
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 246
Joined: Fri Nov 03, 2006 2:00 pm

Re: g++: error: c:/wxBuild/lib/libwx_mswu-3.1.a: No such file or directory

Post by stahta01 » Thu Jan 24, 2019 3:39 am

I will guess the wxWidgets build failed; if it did the cause was likely the "--enable-monolithic" option.
It takes a lot of memory to create an monolithic build of wxWidgets and it can often fail because of memory or command line too long issues.

Tim S.

User avatar
TukingFypo
In need of some credit
In need of some credit
Posts: 8
Joined: Tue Jan 22, 2019 1:16 pm

Re: g++: error: c:/wxBuild/lib/libwx_mswu-3.1.a: No such file or directory

Post by TukingFypo » Mon Jan 28, 2019 12:04 pm

Thank you all, guys.
I was able to properly build wxWidgets via dos command prompt commands (without using msys / configure).
P.S.: Consider this topic closed.

Post Reply