Problem installing wxWidgets on OSX

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
grayfox
In need of some credit
In need of some credit
Posts: 1
Joined: Sun May 01, 2016 2:24 pm

Problem installing wxWidgets on OSX

Postby grayfox » Sun Dec 16, 2018 1:55 pm

I cannot even get pass the configure stage.

macOS Mojave Version 10.14.2
XCode Version 10.1
wxWidgets Version 3.1.2

When I call ./configure, I get the following error:

Code: Select all

checking if C++ compiler (g++ -mmacosx-version-min=10.7) works with SDK/version options... configure: error: in `/Users/grayfox/Desktop/boss/thirdparty/wxwidgets/wxWidgets-3.1.2/bin':
configure: error: no.  Try a different SDK
See `config.log' for more details


In config.log, I got this:

Code: Select all

configure:20265: checking if C++ compiler (g++ -mmacosx-version-min=10.7) works with SDK/version options
configure:20278: g++ -mmacosx-version-min=10.7 -o conftest    conftest.cpp  >&5
clang: warning: libstdc++ is deprecated; move to libc++ with a minimum deployment target of OS X 10.9 [-Wdeprecated]
warning: include path for stdlibc++ headers not found; pass '-std=libc++' on the command line to use the libc++ standard library instead [-Wstdlibcxx-not-found]
1 warning generated.
ld: library not found for -lstdc++
clang: error: linker command failed with exit code 1 (use -v to see invocation)
configure:20278: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "wxWidgets"
| #define PACKAGE_TARNAME "wxwidgets"
| #define PACKAGE_VERSION "3.1.2"
| #define PACKAGE_STRING "wxWidgets 3.1.2"
| #define PACKAGE_BUGREPORT "[email protected]"
| #define PACKAGE_URL ""
| #define __BSD__ 1
| #define __DARWIN__ 1
| /* end confdefs.h.  */
|
| int
| main ()
| {
|
|   ;
|   return 0;
| }
configure:20282: error: in `/Users/grayfox/Desktop/boss/thirdparty/wxwidgets/wxWidgets-3.1.2/bin':
configure:20284: error: no.  Try a different SDK
See `config.log' for more details


Please help!

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 2826
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: Problem installing wxWidgets on OSX

Postby ONEEYEMAN » Tue Dec 18, 2018 4:36 pm

Hi,
What is your exact configure command?

Thank you.

hao
In need of some credit
In need of some credit
Posts: 4
Joined: Thu Dec 20, 2018 3:53 am

Re: Problem installing wxWidgets on OSX

Postby hao » Thu Dec 20, 2018 4:58 am

Try to export an environment variable before you run the configure.

Code: Select all

export wxUSE_MACOSX_VERSION_MIN=10.9


This is used to tell wx the minimal SDK version is 10.9, instead of the default 10.7 that doesn't exist on your current OSX.

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 2826
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: Problem installing wxWidgets on OSX

Postby ONEEYEMAN » Thu Dec 20, 2018 3:45 pm

Hi,
Or just use appropriate configure switch.
And that's why I asked for the exact configure line...

Thank you.


Return to “Compiler / Linking / IDE Related”

Who is online

Users browsing this forum: No registered users and 5 guests