Fatal Runtime Error: Mismatch between the program and library build versions detected. Topic is solved

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
tuk1
Experienced Solver
Experienced Solver
Posts: 62
Joined: Sun Oct 08, 2017 9:36 am

Fatal Runtime Error: Mismatch between the program and library build versions detected.

Post by tuk1 » Tue Oct 23, 2018 2:41 pm

Not sure how to resolve this runtime error, have tried updating library from 3.0.3 to 3.0.4 and rebuilding project but it didn't help.
Mismatch between the program and library build versions detected. The library used 3.0 (wchar_t, Visual C++ 1900, wx containers, compatible with 2.8 and your program used 3.0 (wchar_t, Visual C++ 1915, wx containers, compatible with 2.8
Capture.JPG
Capture.JPG (26.68 KiB) Viewed 858 times
wxWidgets(v3.0.4) - Vs2017(v141) - Win7(x64) - DialogBlocks(v5.15.3_Unicode)

PB
Part Of The Furniture
Part Of The Furniture
Posts: 1970
Joined: Sun Jan 03, 2010 5:45 pm

Re: Fatal Runtime Error: Mismatch between the program and library build versions detected.

Post by PB » Tue Oct 23, 2018 3:46 pm

1900 = MSVC 2015 v14.0
1915 = MSVC 2017 v15.8

Assuming you really used the same compiler (MSVC 2017) for both the library and the application using it, make sure the platform toolset (in project settings, Configuration Properties / General) is also the same (e.g. v140 vs 141).

tuk1
Experienced Solver
Experienced Solver
Posts: 62
Joined: Sun Oct 08, 2017 9:36 am

Re: Fatal Runtime Error: Mismatch between the program and library build versions detected.

Post by tuk1 » Tue Oct 23, 2018 4:06 pm

PB wrote: Assuming you really used the same compiler (MSVC 2017) for both the library and the application using it
=D> ...doh! can't believe I missed that, I've not long moved from vs2015 to vs2017 and still have the old cmd shortcut lurking in my start menu.
wxWidgets(v3.0.4) - Vs2017(v141) - Win7(x64) - DialogBlocks(v5.15.3_Unicode)

Post Reply