Can't build with --disable-sys-libs

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
nmset
Knows some wx things
Knows some wx things
Posts: 29
Joined: Fri Nov 26, 2010 4:48 pm

Can't build with --disable-sys-libs

Postby nmset » Sun Mar 11, 2018 3:04 pm

I am trying to build wxWidgets on Linux after 'git pull' configured with --disable-sys-libs. It constantly fails with this message :

Code: Select all

make: *** No rule to make target '../src/zlib/adler32.c', needed by 'wxzlib_adler32.o'.  Stop.


../src/zlib/ is empty. On github, there's a 'zlib @ 5888671' directory that's pulling from somewhere else. 'git pull' on my machine does not fetch any remote files in src/zlib/ .

Does anyone know how can I solve this issue ?

Thanks.

User avatar
doublemax
Moderator
Moderator
Posts: 12507
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: Can't build with --disable-sys-libs

Postby doublemax » Sun Mar 11, 2018 3:18 pm

You probably didn't get the sub modules.

Read this:
http://www.wxwidgets.org/develop/code-repository/
Use the source, Luke!

nmset
Knows some wx things
Knows some wx things
Posts: 29
Joined: Fri Nov 26, 2010 4:48 pm

Re: Can't build with --disable-sys-libs

Postby nmset » Sun Mar 11, 2018 3:31 pm

That fixed it, thanks.


Return to “Compiler / Linking / IDE Related”

Who is online

Users browsing this forum: Google [Bot] and 6 guests