Building Error (wxUSE_ACCESSIBILITY)

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
leojose
Earned a small fee
Earned a small fee
Posts: 10
Joined: Mon Sep 26, 2005 9:24 am

Building Error (wxUSE_ACCESSIBILITY)

Post by leojose » Wed Sep 28, 2005 8:14 am

Hi all,

I am trying to build the sample 'access' but I get a dialog box that says

Code: Select all

This sample has to be compiled with wxUSE_ACCESSIBILITY

What is wrong? How do I solve this?

leio
Can't get richer than this
Can't get richer than this
Posts: 802
Joined: Mon Dec 27, 2004 10:46 am
Location: Estonia, Tallinn
Contact:

Post by leio » Wed Sep 28, 2005 11:47 am

You need to (re)compile wxMSW with accessibility support, by editing the setup.h and making wxUSE_ACCESSIBILITY 1 there, instead of 0. If you are using ./configure, then there is an argument that you can pass for that.
i said wxMSW, because this works only in wxMSW. Enabling wxUSE_ACCESSIBILITY will only give build errors on other ports, as it is not implemented, nor stubbed. Further, the API is so win32 centric, that I don't really see it possible to implement it on other ports in any sane way with the given API of current wxAccessible.
Compilers: gcc-3.3.6, gcc-3.4.5, gcc-4.0.2, gcc-4.1.0 and MSVC6
OS's: Gentoo Linux, WinXP; WX: CVS HEAD

Project Manager of wxMUD - http://wxmud.sf.net/
Developer of wxGTK;
gtk+ port maintainer of OMGUI - http://www.omgui.org/

Post Reply