Identifier "wxZipStreamLink" is undefined + unresolved externals Topic is solved

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Part Of The Furniture
Part Of The Furniture
Posts: 2957
Joined: Sun Jan 03, 2010 5:45 pm

Re: Identifier "wxZipStreamLink" is undefined + unresolved externals

Post by PB » Fri Dec 16, 2016 9:38 am

Is there a valid "setup.h" file in your "C:\Cpp\wxWidgets\lib\vc_dll\mswu\wx" (DLL debug build) and in "C:\Cpp\wxWidgets\lib\vc_dll\msw\wx" (release build) folders, generated by building wxWidgets with MSVC using "nmake -f BUILD=debug SHARED=1" and "nmake -f BUILD=release SHARED=1" or their IDE equivalents?

I assume you do have setup.h in n your "C:\Cpp\wxWidgets\include\wx\msw" as well as in "C:\Cpp\wxWidgets\include\msvc\wx".

But I still find odd that MSVC IDE complains about missing header files when opening the project, these errors should appear only when building it (and the files cannot be found)...

I assume you can still build and run the minimal sample in DLL debug configuration.

Earned some good credits
Earned some good credits
Posts: 147
Joined: Tue Dec 06, 2011 5:52 pm
Location: Helsinki

Re: Identifier "wxZipStreamLink" is undefined + unresolved externals

Post by Tapsa » Fri Dec 16, 2016 10:23 am

There are "setup.h" file in both mswu and mswud folders as you asked.
I don't have nmake on my PC.

Yes I can still build and run the minimal sample using DLL Debug configuration.
MSVC is so intelligent that it looks for you already beforehand some stuff up.

I have managed to get the errors in my own project down to 2 only.
Error LNK1104 cannot open file 'wxbase31ud_net.lib' Kuvastin C:\Users\Tapsa\Documents\GitHub\Kuvastin\LINK 1
Error (active) identifier "wxZipStreamLink" is undefined Kuvastin c:\Cpp\wxWidgets\include\wx\zipstrm.h 407
I fixed those by building the remaining libs (dunno why they are needed, they should not be).
My project compiles now :)
Just need to fix some unhandled exceptions.

What fixed it?
1. Using exactly the same configuration options (DLL Debug/Release).
2. Some magical edits in vcxproj file copied from minimal.
3. Build everything, even seemingly unrelated and unnecessary libs.

Post Reply