CodeBlocks IDE has no "wxWidgets 3.1.x" option Topic is solved

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
dqf88
Experienced Solver
Experienced Solver
Posts: 55
Joined: Fri Aug 10, 2012 9:59 am

CodeBlocks IDE has no "wxWidgets 3.1.x" option

Post by dqf88 » Tue Aug 16, 2016 5:00 am

CodeBlocks IDE has no "wxWidgets 3.1.x" option, how to solve this problem? Thanks

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 4710
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: CodeBlocks IDE has no "wxWidgets 3.1.x" option

Post by ONEEYEMAN » Tue Aug 16, 2016 1:44 pm

Hi,
There are couple of posts here on those forums about this problem.
Just do a search.

Or just wait for a next release of C::B.

Thank you.

New Pagodi
Super wx Problem Solver
Super wx Problem Solver
Posts: 364
Joined: Tue Jun 20, 2006 6:47 pm
Contact:

Re: CodeBlocks IDE has no "wxWidgets 3.1.x" option

Post by New Pagodi » Tue Aug 16, 2016 6:16 pm

I wrote about some solutions here.

dqf88
Experienced Solver
Experienced Solver
Posts: 55
Joined: Fri Aug 10, 2012 9:59 am

Re: CodeBlocks IDE has no "wxWidgets 3.1.x" option

Post by dqf88 » Thu Aug 18, 2016 12:42 am

New Pagodi wrote:I wrote about some solutions here.
Thanks

dqf88
Experienced Solver
Experienced Solver
Posts: 55
Joined: Fri Aug 10, 2012 9:59 am

Re: CodeBlocks IDE has no "wxWidgets 3.1.x" option

Post by dqf88 » Thu Aug 18, 2016 2:02 am

New Pagodi wrote:I wrote about some solutions here.
The error occured when I builded the program with "wxWidgets is built as a monolithic library" option
Attachments
Image 1.png
Image 1.png (25.69 KiB) Viewed 2392 times

User avatar
doublemax
Moderator
Moderator
Posts: 15507
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: CodeBlocks IDE has no "wxWidgets 3.1.x" option

Post by doublemax » Thu Aug 18, 2016 9:34 am

I can't read Chinese, but that that probably just means that the DLL is missing. You need to copy it into the program directory.
Use the source, Luke!

iwbnwif
Super wx Problem Solver
Super wx Problem Solver
Posts: 274
Joined: Tue Mar 19, 2013 8:52 pm

Re: CodeBlocks IDE has no "wxWidgets 3.1.x" option

Post by iwbnwif » Thu Aug 18, 2016 1:15 pm

Yes it says that the wxWidgets DLL cannot be found.

As Doublemax says, either copy it to the directory where your executable (.EXE) file is. Or perhaps better is to add the directory with your wxWidgets DLLs to the PATH environment variable.
wxWidgets 3.1.2, MinGW64 8.1.0, g++ 8.1.0, Ubuntu 19.04, Windows 10, CodeLite + wxCrafter
Some people, when confronted with a GUI problem, think "I know, I'll use Eclipse RCP". Now they have two problems.

Post Reply