Problems using wxWidgets and macOSX

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
Lamekiller
In need of some credit
In need of some credit
Posts: 1
Joined: Mon Feb 29, 2016 10:56 pm

Problems using wxWidgets and macOSX

Post by Lamekiller » Mon Feb 29, 2016 11:30 pm

Hello everybody!

I'm a completly newbie using wxWidgets, in fact, I'm trying hard to learn how to use, but after 2 weeks trying to install it I haven't got any progress.

Describing the steps that I've done:

1 - Downloaded Code::Blocks for MacOSX: http://www.codeblocks.org/downloads/26 (bottom of page)
2 - Downloaded wxWidgets version 3.0.2: https://wxwidgets.org/downloads/ for MacOS
3 - Extracted on /Users/myUser/wx302/ all files that I've downloaded on wxWidgets
4 - Followed those steps: https://wiki.wxwidgets.org/Building_WxW ... th_MacOS_X
5 - Got some errors while building, but fixed with this ticket: http://trac.wxwidgets.org/ticket/16329 (got some warnings but it builded)
6 - Tried to follow those steps: http://wiki.codeblocks.org/index.php/Wx ... ello_world

And no matter what I do, I aways got those errors:
-------------- Build: Release in Teste de Projeto (compiler: GNU GCC Compiler)---------------

g++ -Winvalid-pch -include wx_pch.h -DWX_PRECOMP -Wall -O2 -c "/Users/gustavo/Documents/Projetos/Teste de Projeto/wx_pch.h" -o wx_pch.h.gch/Release_wx_pch_h_gch
clang: warning: treating 'c-header' input as 'c++-header' when in C++ mode, this behavior is deprecated
error: no suitable precompiled header file found in directory 'wx_pch.h.gch'
1 error generated.
Process terminated with status 1 (0 minute(s), 0 second(s))
0 error(s), 1 warning(s) (0 minute(s), 0 second(s))
I'm completly lost, what do I do? :(

I've saw some people install it very easily, and I got a lot of errors installing and trying to use, even on a Windows 7 emulated on VMWare.

Anyone can help ou support me showing the right way to install it? I've done something wrong? Thanks.

Post Reply