Linker erros in MVS 2008  [SOLVED]

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
User avatar
doublemax
Moderator
Moderator
Posts: 12606
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: Linker erros in MVS 2008  [SOLVED]

Postby doublemax » Mon May 28, 2012 7:50 pm

I was able to build the project, but instead of creating a new project from scratch, i copied the "minimal" sample and added all new files to it.

I guess something in your configuration must be missing, but i don't know what.

Preprocessor definitions:

Code: Select all

WIN32
__WXMSW__
NDEBUG
_UNICODE
_WINDOWS


Linker input files:

Code: Select all

wxbase28u.lib
wxbase28u_net.lib
wxmsw28u_core.lib
wxmsw28u_gl.lib
wxmsw28u_aui.lib
wxtiff.lib
wxjpeg.lib
wxpng.lib
wxzlib.lib
wxregexu.lib
wxexpat.lib
kernel32.lib
user32.lib
gdi32.lib
comdlg32.lib
winspool.lib
winmm.lib
shell32.lib
comctl32.lib
ole32.lib
oleaut32.lib
uuid.lib
rpcrt4.lib
advapi32.lib
wsock32.lib
wininet.lib
libxml2.lib
Use the source, Luke!

comedinha
In need of some credit
In need of some credit
Posts: 9
Joined: Thu May 24, 2012 10:46 pm

Re: Linker erros in MVS 2008

Postby comedinha » Mon May 28, 2012 8:19 pm

Tyy Have missing

Code: Select all

 NDEBUG
_UNICODE


tyy:

Code: Select all

------ Build started: Project: RmE, Configuration: Release Win32 ------
Compiling...
pngfiles.cpp
main.cpp
Linking...
Generating code
Finished generating code
Embedding manifest...
Build log was saved at "file://d:\Tibia\Souce\Map Editor\trunk\RmE\Release\BuildLog.htm"
RmE - 0 error(s), 0 warning(s)
========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========


Return to “Compiler / Linking / IDE Related”

Who is online

Users browsing this forum: DavidHart and 2 guests