2.9.1 VS10, some warnings, does it really matter?? Topic is solved

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
tedzini
Knows some wx things
Knows some wx things
Posts: 34
Joined: Tue Apr 20, 2010 2:30 pm

2.9.1 VS10, some warnings, does it really matter??

Post by tedzini » Tue Jul 05, 2011 2:59 pm

Greetings,

OK; from an earlier post today, I found and grabbed the old version 2.9.1:

http://sourceforge.net/projects/wxwindo ... e/download

Used the VS10 solution, and it seemed to build all the libraries, BUT, I got an 'error' and some copious warning
messages. There seemed to be a possible fix for one, and perhaps no actual 'solution' for other.
MY QUESTION: do these warnings and error below really matter? I list the warnings and errors below with
VS10, IDE Debug build, (F7):

<snip>
1>------ Build started: Project: wxscintilla, Configuration: Debug Win32 ------
2>------ Build started: Project: richtext, Configuration: Debug Win32 ------
1> Invalid path
1> 0 File(s) copied
1>C:\Program Files\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets(103,5): error MSB3073: The command "xcopy ..\..\include\wx\msw\setup.h ..\..\lib\vc_lib\mswud\wx\ /Y
1>C:\Program Files\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets(103,5): error MSB3073: :VCEnd" exited with code 4
<snip>

And warnings for the libraries as in:

<snip>
6>C:\Program Files\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppBuild.targets(1151,5): warning MSB8012: TargetPath(C:\wxWidgets-2.9.1\build\msw\..\..\lib\vc_lib\aui.lib) does not match the Library's OutputFile property value (C:\wxWidgets-2.9.1\lib\vc_lib\wxmsw29ud_aui.lib). This may cause your project to build incorrectly. To correct this, please make sure that $(OutDir), $(TargetName) and $(TargetExt) property values match the value specified in %(Lib.OutputFile).
6>C:\Program Files\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppBuild.targets(1153,5): warning MSB8012: TargetName(aui) does not match the Library's OutputFile property value (wxmsw29ud_aui). This may cause your project to build incorrectly. To correct this, please make sure that $(OutDir), $(TargetName) and $(TargetExt) property values match the value specified in %(Lib.OutputFile).
6> wx_vc10_aui.vcxproj -> C:\wxWidgets-2.9.1\build\msw\..\..\lib\vc_lib\aui.lib
<snip>

And finally, warnings as in:

<snip>
15>..\..\src\msw\main.cpp(185): warning C4535: calling _set_se_translator() requires /EHa
<snip>
.
.
.
<snip>
15>..\..\src\msw\thread.cpp(568): warning C4535: calling _set_se_translator() requires /EHa
<snip>

I found some posts regarding the former warning:

<snip>
I did find two trac entries which report the same error message you got, with possible fixes:
http://trac.wxwidgets.org/ticket/12010
http://trac.wxwidgets.org/ticket/12300

It's just strange that it compiled for me out of the box. Maybe it's because i opened wx.dsw and not one of the .sln or .vcxproj files.

Workaround 2 (better & easier one):
1. Close the IDE.
2. Open all .vcxproj files in Notepad++ or another editor.
3. Search&Replace all "$(INTDIR) $(OUTDIR)" to "$(INTDIR);$(OUTDIR)"
(without the quotes)
4. Reopen the solution and build it.
<snip>

OK....And, finally I see this for the latter warning:

<snip>
On Wed, 11 May 2011 18:18:13 -0700 (PDT) Herb Thompson <[email protected]> wrote:

HT> Building SVN 67729 with VC 2010 SP1 gives "warning C4535: calling
HT> _set_se_translator() requires /EHa" for:
HT> ..\..\src\msw\thread.cpp(569)
HT> ..\..\src\msw\main.cpp(185)

To the best of my knowledge this warning is harmless. And getting rid of
it is unfortunately difficult because the project files are generated by a
tool which doesn't support specifying special options for individual files.
So for the observable future we'll just have to live with it.

Regards,
VZ
<snip>

If anyone read this far and replied, thanks!

:-)

ted

stahta01
Super wx Problem Solver
Super wx Problem Solver
Posts: 291
Joined: Fri Nov 03, 2006 2:00 pm

Re: 2.9.1 VS10, some warnings, does it really matter??

Post by stahta01 » Tue Jul 05, 2011 4:24 pm

C:\Program Files\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets(103,5): error MSB3073: The command "xcopy ..\..\include\wx\msw\setup.h
You need to create include\wx\msw\setup.h by copying include\wx\msw\setup0.h.
Note: Do NOT rename or edit setup0.h; you need to copy it.
Note: Editing of include\wx\msw\setup.h is permitted/suggested by some sites/people.

Then start at the beginning on building wxWidgets.

Tim S.

tedzini
Knows some wx things
Knows some wx things
Posts: 34
Joined: Tue Apr 20, 2010 2:30 pm

Re: 2.9.1 VS10, some warnings, does it really matter??

Post by tedzini » Wed Jul 06, 2011 1:37 pm

Hi Tim,

I am stupid; The problem was on the ACL for the folder which setup.h needs to copy to. I *forgot* to
add myself wrx access. oops. thanks for your reply.

Post Reply