2.9.2 VS10 Topic is solved

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
tedzini
Knows some wx things
Knows some wx things
Posts: 34
Joined: Tue Apr 20, 2010 2:30 pm

2.9.2 VS10

Post by tedzini » Tue Jul 05, 2011 2:06 pm

Greetings,

I need to upgrade to VS2010 because our University student computing labs will no longer be supporting VS2010 for any classes,
which was done for 2.9.1.

Digging through the archives of this forum I found a link to obtain the VS2010 solution/project. However this morning I found to
my surprise that 2.9.1 download wasn't there. So, I decided to give 2.9.2 a try as that was readily available.
I then did F7 build (Debug/Win32) and the build produced the following errors and warnings:


13>c1xx : fatal error C1083: Cannot open source file: '..\..\src\common\datacmn.cpp': No such file or directory
15>..\..\src\msw\main.cpp(185): warning C4535: calling _set_se_translator() requires /EHa
15>..\..\src\msw\thread.cpp(569): warning C4535: calling _set_se_translator() requires /EHa
20>c1 : fatal error C1083: Cannot open source file: '..\..\src\png\pnggccrd.c': No such file or directory
20>c1 : fatal error C1083: Cannot open source file: '..\..\src\png\pngvcrd.c': No such file or directory

I'm using 10.0.30319, which is the current University package that is available to students and that will be installed
on all win7 platforms across campus.

I found a couple of posts regarding the /EHa switch-- about the need to change the config settings, but then
the projects were being built from nmake command line and not within the IDE itself, no?? :?:

Could someone either point me to a fresh 2.9.1 download, or explain how to modify the problems with
the build to remove the above errors?

thanks very much in advance!

-Ted

User avatar
doublemax
Moderator
Moderator
Posts: 14319
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: 2.9.2 VS10

Post by doublemax » Tue Jul 05, 2011 2:53 pm

I just tested the freshly released 2.9.2 with VS2010 Professional and it compiled out of the box.

But i always use the "wx_vc7.sln" solution and let it convert as this seems to be most reliable.
Use the source, Luke!

tedzini
Knows some wx things
Knows some wx things
Posts: 34
Joined: Tue Apr 20, 2010 2:30 pm

Re: 2.9.2 VS10

Post by tedzini » Wed Jul 06, 2011 2:06 pm

Dang! you are right, that all converted, and then compiled perfectly under VS2010!

There were the pesky warnings about output filename mismatches (noted in an earlier, 2nd post of mine),
but nevertheless they must be harmless insofar as all the static libraries for debug/release built with no errors.

thanks!

t

Post Reply