Problem whne playing with bakefile

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
Experienced Solver
Experienced Solver
Posts: 72
Joined: Mon Nov 08, 2004 3:36 pm

Problem whne playing with bakefile

Post by romeo9423 » Sun Dec 09, 2007 1:23 pm


I am trying to learn bakefile and to start I wanted to regenerate projects for visual studio 2005 located in wxWidgets-2.8.7\build\bakefiles\.
So I have deleted the msw folder.

Then I have tried to type > bakefile_gen -B --formats msvs2005prj
but I get a 0 files modified and nothing happens.
After I tried with msvc as format and at the end bakefile shouts at me the following:

[123/137] generating msvc from wx.bkl
Traceback (most recent call last):
File "c:\Program Files\Bakefile\src\", line 197, in ?
File "c:\Program Files\Bakefile\src\", line 176, in run
if not writer.write():
File "c:\Program Files\Bakefile\src\", line 282, in write
f = __openFile(file)
File "c:\Program Files\Bakefile\src\", line 160, in __openFile
f = open(filename, 'w+t')
IOError: [Errno 2] No such file or directory: '../msw/'
Error executing the script!
[bakefile_gen] error: bakefile exited with error

So from what I understand it's trying to open ../msw/ but why because the goal is to generate this file .

In need of some credit
In need of some credit
Posts: 1
Joined: Sat Mar 08, 2008 2:29 pm

Post by erwinew » Sat Mar 08, 2008 2:33 pm

A late response, but I had the same problem. The solution is to use the command:

<wxWidgets>\build\bakefiles\bakefile_gen -B -f msvc

-- Erwin

Post Reply