Regression in 2.8.4? nmake fails, cannot find chkconf.h Topic is solved

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
fx
Earned a small fee
Earned a small fee
Posts: 10
Joined: Sat Apr 28, 2007 7:03 pm

Regression in 2.8.4? nmake fails, cannot find chkconf.h

Post by fx » Sun May 20, 2007 4:13 pm

Building 2.8.4 fails using nmake because it doesn't find chkconf.h. I didn't have this problem in 2.8.0.

I'm calling nmake from build\msw directory which contains makefile.vc.

Suggestions?

UPDATE: Using wxWidgets-2.8.4.zip instead of wxMSW-2.8.4.zip fixed the problem.
I'm guessing that wxMSW-2.8.4.zip contains an error causing an import statement to point to the wrong directory.



System:
wxWidgets 2.8.4 (from wxMSW-2.8.4.zip)
MSVC 2005 Express SP1 in Windows XP SP2

Log:
C:\wxWidgets-2.8.4\build\msw>nmake -f makefile.vc BUILD=release WXUNIV=0 SHARED=0 RUNTIME_LIBS=static USE_RTTI=0 UNICODE=0 USE_GUI=1 MONOLITHIC=1 CPPFLAGS="/GS /D_CRT_SECURE_NO_DEPRECIATE"

Microsoft (R) Program Maintenance Utility Version 7.00.8882
Copyright (C) Microsoft Corp 1988-2000. All rights reserved.

cl /c /nologo /TC /Fovc_msw\wxregex_regcomp.obj /MT /DWIN32 /Fd..\..\l
ib\vc_lib\wxregex.pdb /O2 /I..\..\include /I..\..\lib\vc_lib\msw /D__WXMSW__
/GS /D_CRT_SECURE_NO_DEPRECIATE ..\..\src\regex\regcomp.c
regcomp.c
..\..\include\wx/platform.h(279) : fatal error C1083: Cannot open include file:
'wx/chkconf.h': No such file or directory
NMAKE : fatal error U1077: 'cl' : return code '0x2'
Stop.
Last edited by fx on Fri Jun 22, 2007 5:28 pm, edited 1 time in total.

stahta01
Super wx Problem Solver
Super wx Problem Solver
Posts: 404
Joined: Fri Nov 03, 2006 2:00 pm

Re: Regression in 2.8.4? nmake fails, cannot find chkconf.h

Post by stahta01 » Wed May 23, 2007 8:07 pm

fx wrote: System:
MSVC 2005 Express SP1

Microsoft (R) Program Maintenance Utility Version 7.00.8882
This Version 7.00.8882 does NOT match MSVC 2005 Express SP1.

Try

Code: Select all

CALL "%VS80COMNTOOLS%vsvars32.bat"
nmake -f makefile.vc BUILD=release WXUNIV=0 SHARED=0 RUNTIME_LIBS=static USE_RTTI=0 UNICODE=0 USE_GUI=1 MONOLITHIC=1 CPPFLAGS="/GS /D_CRT_SECURE_NO_DEPRECIATE"

fx
Earned a small fee
Earned a small fee
Posts: 10
Joined: Sat Apr 28, 2007 7:03 pm

Re: Regression in 2.8.4? nmake fails, cannot find chkconf.h

Post by fx » Thu May 24, 2007 7:07 am

stahta01 wrote:
fx wrote: System:
MSVC 2005 Express SP1

Microsoft (R) Program Maintenance Utility Version 7.00.8882
This Version 7.00.8882 does NOT match MSVC 2005 Express SP1.

...
When you run "nmake -f makefile.vc" from build/msw, does it work for you?

I tried using nmake 8.00.50727.762, but it produces the same results.
BTW, version 7.00.8882 is from Microsoft Platform SDK's bin directory.

Unless the above nmake command works for you, it seems this wxWidgets-2.8.4 bug exists for MSVC 2005 and possibly MSVC 2003, too.

stahta01
Super wx Problem Solver
Super wx Problem Solver
Posts: 404
Joined: Fri Nov 03, 2006 2:00 pm

Re: Regression in 2.8.4? nmake fails, cannot find chkconf.h

Post by stahta01 » Thu May 24, 2007 1:25 pm

fx wrote:
stahta01 wrote:
fx wrote: System:
MSVC 2005 Express SP1

Microsoft (R) Program Maintenance Utility Version 7.00.8882
This Version 7.00.8882 does NOT match MSVC 2005 Express SP1.

...
When you run "nmake -f makefile.vc" from build/msw, does it work for you?

I tried using nmake 8.00.50727.762, but it produces the same results.
BTW, version 7.00.8882 is from Microsoft Platform SDK's bin directory.

Unless the above nmake command works for you, it seems this wxWidgets-2.8.4 bug exists for MSVC 2005 and possibly MSVC 2003, too.
It works for me. I ran the command I posted and it worked. I will try again using the zip download could be it is bad.
It worked with the zip file also.

Tim S

fx
Earned a small fee
Earned a small fee
Posts: 10
Joined: Sat Apr 28, 2007 7:03 pm

Re: Regression in 2.8.4? nmake fails, cannot find chkconf.h

Post by fx » Thu May 24, 2007 6:27 pm

stahta01 wrote: It works for me. I ran the command I posted and it worked. I will try again using the zip download could be it is bad.
It worked with the zip file also.

Tim S
That is a fantastic idea, I'll also try downloading a different .zip and see if that works. My problem happened with:

filename: wxMSW-2.8.4.zip
md5sum: 72a614037769a7d8ad7c5eb9ed9d887c

stahta01
Super wx Problem Solver
Super wx Problem Solver
Posts: 404
Joined: Fri Nov 03, 2006 2:00 pm

Post by stahta01 » Sat May 26, 2007 12:57 pm

You are running the following command before doing the nmake right?
Tim S

Code: Select all

CALL "%VS80COMNTOOLS%vsvars32.bat" 

fx
Earned a small fee
Earned a small fee
Posts: 10
Joined: Sat Apr 28, 2007 7:03 pm

Post by fx » Sat May 26, 2007 10:32 pm

stahta01 wrote:You are running the following command before doing the nmake right?
Tim S

Code: Select all

CALL "%VS80COMNTOOLS%vsvars32.bat" 
Yes, I tried calling that manually before the build. Same result.

I also tried opening the command prompt by using the "Visual Studio 2005 Command Prompt" shortcut. Same result :(

I was on the road, but I'm back now and will try a different zip file.

fx
Earned a small fee
Earned a small fee
Posts: 10
Joined: Sat Apr 28, 2007 7:03 pm

Post by fx » Fri Jun 22, 2007 5:29 pm

The solution is to use wxWidgets-2.8.4.zip instead of wxMSW-2.8.4.zip.

I'm guessing that wxMSW-2.8.4.zip contains an error causing an import statement to point to the wrong directory.

stahta01
Super wx Problem Solver
Super wx Problem Solver
Posts: 404
Joined: Fri Nov 03, 2006 2:00 pm

Post by stahta01 » Mon Jun 25, 2007 4:20 am

fx wrote:The solution is to use wxWidgets-2.8.4.zip instead of wxMSW-2.8.4.zip.

I'm guessing that wxMSW-2.8.4.zip contains an error causing an import statement to point to the wrong directory.
If I recall directory, the main difference between wxWidgets-2.8.4.zip and wxMSW-2.8.4.zip is that wxMSW-2.8.4.zip has some files removed that are not supposed to be needed by windows. So, it may be a missing file in wxMSW-2.8.4.zip that is needed. If you figure out the needed file(s) please post it.
Thanks
Tim S

Post Reply