Page 1 of 1

cannot find `WXU_2.6.2'

Posted: Wed Feb 14, 2007 8:25 pm
by ronoc
Hi,
I am trying to run something that is looking for.

>>/usr/lib/libwx_gtk2u_core-2.6.so.0: version `WXU_2.6.2' not found >>(required by ./config_soft_v12)

So I run ubuntu dapper. I put the dist line in my sources.list but adding the key would not work. The instructions from this site dont work:

sudo curl http://www.tt-solutions.com/vz/key.asc | apt-key add

errors with

gpg: can't open `': No such file or directory
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 1328 100 1328 0 0 6809 0 --:--:-- --:--:-- --:--:-- 0
the file is there. What silly mistake am I making :) (unix newbie)

I have installed through apt-get the wx2.8-i18n but I still get the same error.
Anybody have any ideas?

Conor

Posted: Thu Feb 15, 2007 11:01 am
by DavidHart
Hi Conor,

I was hoping that someone with more ubuntu experience would answer this, but let me have a go.

/usr/lib/libwx_gtk2u_core-2.6.so.0 is one of the standard wxWidgets libraries, If it isn't there, wxWidgets 2.6 isn't installed. However it's worth checking, as wxWidgets doesn't automatically install to /usr/lib, but to /usr/local/lib. If you do have the libs, but they're in /usr/local/lib, symlinking them to /usr/lib should solve your problem.

If you don't, then you need to install wxWidgets 2.6.2 or 3. You might find that later versions work, but they might not (and you'd probably need to rename them to fool the program into thinking that they are 2.6.). So why not use the standard wx package that comes with dapper? That is probably the correct version.

If for some reason this doesn't work, I suggest you do things the tarball way: download 2.6.2 from http://biolpc22.york.ac.uk/pub/2.6.2/wx ... .2.tar.bz2 and follow the instructions in INSTALL.txt, with the exception of redirecting the libs with the additional configure phrase --libdir=/usr/lib. So your configure line would probably be:
../configure --with-gtk --libdir=/usr/lib --enable-unicode
(or the same without the unicode bit). After make/sudo make install/sudo ldconfig, that program should now run.

Regards,

David

Posted: Mon Feb 19, 2007 10:48 pm
by ronoc
Hi David,
Thanks so much for your help.
I have done what you said and it turns out the libs were installed in /usr/lib
Therefore I went straight to install from the tar. This seemed to work fine but now when I try to run the program which depends on this it throws the following errors.

>Fatal Error: Mismatch between the program and library build versions >detected.
>The library used 2.6 (no debug,Unicode,compiler with C++ ABI 1002,wx >containers,compatible with 2.4),
>and your program used 2.6 (no debug,Unicode,compiler with C++ ABI >1002,wx containers,compatible with 2.2,compatible with 2.4).
>Aborted

What should I do next. Uninstall everything and try again?
Conor

Posted: Tue Feb 20, 2007 12:43 am
by Auria
ronoc wrote: >Fatal Error: Mismatch between the program and library build versions >detected.
>The library used 2.6 (no debug,Unicode,compiler with C++ ABI 1002,wx >containers,compatible with 2.4),
>and your program used 2.6 (no debug,Unicode,compiler with C++ ABI >1002,wx containers,compatible with 2.2,compatible with 2.4).
>Aborted
The only difference i see is the 2.2 compatibility.I have no idea if this can be the error, but maybe configure with --enable-compat22 [if it exists, i'm on 2.8]?

And can't you just install wx 2.6 from the repos?

Posted: Tue Feb 20, 2007 5:57 am
by biplab
--enable-compat22 option exists in wxWidgets 2.6.x series. So reconfigure your wxWidgets with this additional option. Your configure command may look like following.

Code: Select all

../configure --with-gtk --libdir=/usr/lib --enable-unicode --enable-compat22
Now recompile it and install it. It should solve the problem.

Please remember that this option does not exist in wxWidgets 2.8.0

Posted: Sat Feb 24, 2007 2:51 pm
by ronoc
all good guys,
works fine now.

thanks for your help
conor