Problems Compiling on Mac iBook G4 (Mac OS X 10.4.8) Topic is solved

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
Prophet05
Earned a small fee
Earned a small fee
Posts: 21
Joined: Thu Oct 19, 2006 9:24 am

Problems Compiling on Mac iBook G4 (Mac OS X 10.4.8)

Post by Prophet05 » Fri Jan 12, 2007 12:50 pm

Hi,

i tried to compile wxMac 2.8.0 on my Apple iBook but for some reason i get a compiler error.

I configured like this:

Code: Select all

./configure --enable-unicode --disable-debug --enable-shared
Then i started make but i get following error:

Code: Select all

../src/common/imagtga.cpp: In function `int ReadTGA(wxImage*, wxInputStream&)':
../include/wx/scopeguard.h:106: error: 'wxScopeGuardImplBase::wxScopeGuardImplBase(const wxScopeGuardImplBase&)' is protected
../src/common/imagtga.cpp:191: error: within this context
../include/wx/scopeguard.h:106: error: 'wxScopeGuardImplBase::wxScopeGuardImplBase(const wxScopeGuardImplBase&)' is protected
../src/common/imagtga.cpp:191: error: within this context
../include/wx/scopeguard.h:104: error: 'wxScopeGuardImplBase::~wxScopeGuardImplBase()' is protected
../src/common/imagtga.cpp:191: error: within this context
../include/wx/scopeguard.h:104: error: 'wxScopeGuardImplBase::~wxScopeGuardImplBase()' is protected
../src/common/imagtga.cpp:191: error: within this context
make: *** [coredll_imagtga.o] Error 1
I use:

Code: Select all

$ g++ --version
powerpc-apple-darwin8-g++-4.0.0 (GCC) 4.0.0 20041026 (Apple Computer, Inc. build 4061)
Copyright (C) 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

$ make --version
GNU Make 3.80
Copyright (C) 2002  Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.

$ ../configure --version
wxWidgets configure 2.8.0
generated by GNU Autoconf 2.59
Copyright (C) 2003 Free Software Foundation, Inc.
This configure script is free software; the Free Software Foundation
gives unlimited permission to copy, distribute and modify it.
Can you guys help me?

Greetings, Prophet05

Auria
Site Admin
Site Admin
Posts: 6695
Joined: Thu Sep 28, 2006 12:23 am
Contact:

Post by Auria » Wed Jan 17, 2007 12:29 am

No idea if this is related in any way, but GCC 4.0.0 is known for having many bugs and many apps and libs won't compile under it - you should try updating to a later version perhaps.

Trikko
Experienced Solver
Experienced Solver
Posts: 94
Joined: Tue Oct 18, 2005 8:28 pm
Location: Venice, IT
Contact:

Post by Trikko » Mon Feb 12, 2007 12:53 pm

I have the same problem compiling wx2.8 for ppc. On mactel it works. I've disabled support for tga to avoid problem. On configure: --disable-tga

Have you solved this problem?

User avatar
tierra
Site Admin
Site Admin
Posts: 1340
Joined: Sun Aug 29, 2004 7:14 pm
Location: Salt Lake City, Utah, USA
Contact:

Post by tierra » Mon Feb 12, 2007 6:58 pm

Trikko wrote:I have the same problem compiling wx2.8 for ppc. On mactel it works.
I am on an Intel Mac, but building with a PPC target has worked fine for me in the past using Universal Binaries with GCC 4.0, and I'm pretty sure I've built 2.8.0 just fine for universal, and I know it works fine for current CVS HEAD.

Sorry, I'm not going to be of much help without a PPC machine to test with.

Prophet05
Earned a small fee
Earned a small fee
Posts: 21
Joined: Thu Oct 19, 2006 9:24 am

Post by Prophet05 » Mon Feb 26, 2007 5:52 am

I've solved the problem by using the Darwin Port for wxWidgets. but ill try its again this evening. THanks for your help guys!

Post Reply