Microsoft Visual Studio 2005+wxWidgets 2.8.0 rc1 compiling

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
roarek82
Earned a small fee
Earned a small fee
Posts: 13
Joined: Sat Aug 26, 2006 2:40 am

Microsoft Visual Studio 2005+wxWidgets 2.8.0 rc1 compiling

Post by roarek82 » Tue Nov 21, 2006 3:36 am

Code: Select all

------ Rebuild All started: Project: Projekt, Configuration: Debug Win32 ------
Deleting intermediate and output files for project 'Projekt', configuration 'Debug|Win32'
Compiling...
Projekt_wdr.cpp
c:\program files\wxdesigner\wx/chkconf.h(122) : fatal error C1189: #error :  "wxUSE_FS_ARCHIVE must be defined."
Projekt.cpp
c:\program files\wxdesigner\wx/chkconf.h(122) : fatal error C1189: #error :  "wxUSE_FS_ARCHIVE must be defined."
Generating Code...
Build log was saved at "file://c:\Documents and Settings\wisnia\Moje dokumenty\Visual Studio 2005\Projects\Test\Test\Debug\BuildLog.htm"
Projekt - 2 error(s), 0 warning(s)
========== Rebuild All: 0 succeeded, 1 failed, 0 skipped ==========
Problem in not in my file but chkconf.h
How to solve it?
Anybody help?
Regards
Kamil

User avatar
tierra
Site Admin
Site Admin
Posts: 1343
Joined: Sun Aug 29, 2004 7:14 pm
Location: Salt Lake City, Utah, USA
Contact:

Post by tierra » Tue Nov 21, 2006 8:48 am

If you've setup global MSVC include directories for wxWidgets, it may be possible that it's picking up setup.h settings from an older install of wxWidgets based on the order of your include paths.

But I'm confused about the error coming from what looks like your installation of wxDesigner, and not from wxWidgets. Looks more like it could be a problem with an older version of wxDesigner headers that just don't work with the newest wxWidgets code.

Post Reply