Compiling wxWidgets 3.1.2 on macOS Mojave

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 3204
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: Compiling wxWidgets 3.1.2 on macOS Mojave

Post by ONEEYEMAN » Wed Jan 23, 2019 4:51 pm

Hi,
As it had been pointed out the correct option is

-with-macosx-sdk

You can also run

Code: Select all

../configure --help
to check for proper syntax.

Thank you.

arcode0
In need of some credit
In need of some credit
Posts: 1
Joined: Sat May 11, 2019 9:29 pm

Re: Compiling wxWidgets 3.1.2 on macOS Mojave

Post by arcode0 » Sat May 11, 2019 9:44 pm

I got it working with the following process and configure command.

I used the instructions inside wxWidgets-3.2.1/docs/osx/install.txt
mkdir build-cocoa-debug
cd build-cocoa-debug
../configure --enable-debug
make
First get the path to your sdk

Code: Select all

xcode-select --print-path
I followed it and got
/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk/
Then run a configure command with additional flags. I had to change the version from the default 10.7 to 10.9 after an error and based on the recommendations I read here and in other places.

Code: Select all

../configure --enable-debug --with-macosx-sdk=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk --with-macosx-version-min=10.9
then

Code: Select all

make
I had:
xcode 10.2.1
wxwidgets 3.1.2
macOS 10.14.4

Hope that helps anyone.

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 3204
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: Compiling wxWidgets 3.1.2 on macOS Mojave

Post by ONEEYEMAN » Sat May 11, 2019 10:49 pm

Hi,
You can successfully skip the

Code: Select all

--with-macosx-sdk
It will just be picked up automatically.

Thank you.

Post Reply