Building wxWidgets on Ubuntu 17.10.1 fails  [SOLVED]

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
fishnet37222
Knows some wx things
Knows some wx things
Posts: 32
Joined: Sat May 06, 2017 1:40 pm

Building wxWidgets on Ubuntu 17.10.1 fails

Postby fishnet37222 » Tue Mar 13, 2018 3:40 pm

I'm trying to build wxWidgets 3.1.1 on Ubuntu 17.10.1 but it keeps failing with the error below.

Code: Select all

../src/gtk/webview_webkit2.cpp:414:9: error: ‘WX_WEB_EXTENSIONS_DIRECTORY’ was not declared in this scope


I issued the command "apt list --installed | grep webkit2gtk" and the output is below.

Code: Select all

libwebkit2gtk-4.0-37/artful-updates,artful-security,now 2.18.6-0ubuntu0.17.10.1 amd64 [installed]
libwebkit2gtk-4.0-dev/artful-updates,artful-security,now 2.18.6-0ubuntu0.17.10.1 amd64 [installed]


I searched the wxWidgets Trac for that error message and only one bug showed up in the results. That bug was about a different issue, though.

DavidHart
Site Admin
Site Admin
Posts: 3719
Joined: Thu Jan 12, 2006 6:23 pm
Location: IoW, UK

Re: Building wxWidgets on Ubuntu 17.10.1 fails

Postby DavidHart » Tue Mar 13, 2018 3:58 pm

Hi,

At a guess, you're missing the -dev package. For 17.10 that seems to be libwebkit2gtk-4.0-dev (there doesn't seem to be a metapackage libwebkit2gtk-dev).

If that doesn't help, the unofficial wx3.1.1 packages mentioned here use the older libwebkitgtk-dev.

Regards,

David

fishnet37222
Knows some wx things
Knows some wx things
Posts: 32
Joined: Sat May 06, 2017 1:40 pm

Re: Building wxWidgets on Ubuntu 17.10.1 fails

Postby fishnet37222 » Tue Mar 13, 2018 4:01 pm

I included a list of the installed packages with "webkit2gtk" in their name, and the "-dev" package is installed.

By the way, I also tried building the stable 3.0.4 release and got the same error.

DavidHart
Site Admin
Site Admin
Posts: 3719
Joined: Thu Jan 12, 2006 6:23 pm
Location: IoW, UK

Re: Building wxWidgets on Ubuntu 17.10.1 fails

Postby DavidHart » Tue Mar 13, 2018 4:44 pm

Oh, sorry: I missed that on the second line.

Must you use webkit2? I know that wx builds against libwebkitgtk-dev.

If you must, what was your configure line? And were there any webview-related errors in its output (see also ${build-dir}/config.log)?

fishnet37222
Knows some wx things
Knows some wx things
Posts: 32
Joined: Sat May 06, 2017 1:40 pm

Re: Building wxWidgets on Ubuntu 17.10.1 fails  [SOLVED]

Postby fishnet37222 » Wed Mar 14, 2018 3:01 pm

I ended up using the pre-built binaries available from http://codelite.org/LiteEditor/WxWidgets31Binaries#toc2. They seem to work without any issues and they were linked to from the wxWidgets downloads page.


Return to “Compiler / Linking / IDE Related”

Who is online

Users browsing this forum: ColleenKobe and 2 guests