Page 1 of 2

New layout of the forum

Posted: Fri Sep 03, 2004 2:46 pm
by Jorg
Hi guys,

Ryan mentioned some more logical layout, I agreed the forum topics (about the forum itself) were a bit misplaced. So I added two sections for the wxWidgets Forum itself, and renamed some categories.

I hope this is to everyone's liking ... :wink:

- Jorgen

Posted: Fri Sep 03, 2004 2:59 pm
by Ryan Norton
Looks Good!

One last request - is there a way to stick "moderator" or "admistrator" under our names?

Posted: Fri Sep 03, 2004 3:04 pm
by Jorg
You mean like behind your name ? If you are visible online, your name is green at the bottom which means you are a moderator to others. Other people are marked blue I think. Admins are marked orange ..

In every forum people are reading they see on the top who is moderating it. :-)

By the way, your avatar is broken. :o

- Jorgen

Posted: Fri Sep 03, 2004 4:03 pm
by Ryan Norton
Jorg wrote:By the way, your avatar is broken. :o
Thanks - fixed.

BTW - I was just bringing up the moderator thing because on other forums it does this - also, people can't tell who a moderator is by just looking at posts...

Thanks!

Ryan

Posted: Sat Sep 04, 2004 11:30 pm
by Ryan Norton
Jorg - as a request, mayby you could shorten the width of the message table? It extends even beyond the 1024x800 range :)

Posted: Mon Sep 06, 2004 1:20 pm
by Jorg
Ryan Norton wrote:Jorg - as a request, mayby you could shorten the width of the message table? It extends even beyond the 1024x800 range :)
What exactly do you mean? The forum can be sized until 849 pixels in width without the browser refusing to resize the board and showing slider bars..

- Jorgen

Posted: Mon Sep 06, 2004 1:38 pm
by Ryan Norton
Jorg wrote: What exactly do you mean? The forum can be sized until 849 pixels in width without the browser refusing to resize the board and showing slider bars..

- Jorgen
Well, on IE it always show the slider bars on the bottom, even when maximized in 1024x800 mode...

Posted: Mon Sep 06, 2004 1:44 pm
by Ryan Norton
Ryan Norton wrote:
Jorg wrote: What exactly do you mean? The forum can be sized until 849 pixels in width without the browser refusing to resize the board and showing slider bars..

- Jorgen
Well, on IE it always show the slider bars on the bottom, even when maximized in 1024x800 mode...
OK - Firefox and Opera perform correctly - this is an IE issue. Must be something in the css code someplace...

Posted: Mon Sep 06, 2004 2:03 pm
by Jorg
I see. Sorry but indeed I use FireFox ever since stupid IE was so vulnerable for severe security attacks so I didn't noticed this .. I never switched back because I like FF very much, and under Linux I have the same browser.

So funny how SP2 only patched some Active X holes in IE. Whenever you check the "allow active X" again you get the same situation back ;-) no sir, no more IE for me.

- Jorgen

Posted: Mon Sep 06, 2004 2:18 pm
by Ryan Norton
Jorg wrote:I see. Sorry but indeed I use FireFox ever since stupid IE was so vulnerable for severe security attacks so I didn't noticed this .. I never switched back because I like FF very much, and under Linux I have the same browser.

So funny how SP2 only patched some Active X holes in IE. Whenever you check the "allow active X" again you get the same situation back ;-) no sir, no more IE for me.

- Jorgen
That's exactly why I use I.E. - ActiveX controls. They are really neat, have a ton of functionality, and can be programmed in C++.

Of course, that's the problem too - instead of doing neat things to trick people into installing annoyances...

However, now people are migrating from those to using java apps with security holes in them, so it's only a matter of time before FireFox has the exact same problems.

RedSheriff is already using java to do their dirty work, and there are plenty more already there....

Anyway, I'll check out the html a bit...

Posted: Mon Sep 06, 2004 2:26 pm
by Ryan Norton
Problem found -

<td width="125" height="69" class="logo" align="left"><a href="index.php"><img src="./templates/Morpheus/images/logo_left.gif" width="125" height="69" alt="wxWidgets Discussion Forum Forum Index" /></a></td>
<td width="100%" class="logo" align="center" valign="middle" style="color: #FFF; font-family: Arial;"><span style="font-size: 16px; font-weight: bold;">wxWidgets Discussion Forum</span><br /><span style="font-size: 14px;">Discussion forum for wxWidgets C++ / Python programming</span></td>
<td width="125" height="69" class="logo" align="right"><img src="./templates/Morpheus/images/logo_right.gif" width="125" height="69" /></td>

Which is at the top of the body, should be changed to something like the following:

<td width="10%" height="69" class="logo" align="left"><a href="index.php"><img src="./templates/Morpheus/images/logo_left.gif" width="125" height="69" alt="wxWidgets Discussion Forum Forum Index" /></a></td>
<td width="80%" class="logo" align="center" valign="middle" style="color: #FFF; font-family: Arial;"><span style="font-size: 16px; font-weight: bold;">wxWidgets Discussion Forum</span><br /><span style="font-size: 14px;">Discussion forum for wxWidgets C++ / Python programming</span></td>
<td width="10%" height="69" class="logo" align="right"><img src="./templates/Morpheus/images/logo_right.gif" width="125" height="69" /></td>

I.E. the width values would extend beyond 100%, so just change them so that it evens out to 100%

Posted: Mon Sep 06, 2004 3:55 pm
by tierra
See, now if you spent half as much time fixing wx bugs, it'd be perfect :D

Posted: Mon Sep 06, 2004 6:53 pm
by Jorg
I have changed the layout as you suggested Ryan, can you check if it will work under IE ? This is the changed code:

[syntax="html"]
<td width="10%" height="69" class="logo" align="left"><a href="index.php"><img src="./templates/Morpheus/images/logo_left.gif" width="125" height="69" alt="wxWidgets Discussion Forum Forum Index" /></a></td>
<td width="80%" class="logo" align="center" valign="middle" style="color: #FFF; font-family: Arial;"><span style="font-size: 16px; font-weight: bold;">wxWidgets Discussion Forum</span><br /><span style="font-size: 14px;">Discussion forum for wxWidgets C++ / Python programming</span></td>
<td width="10%" height="69" class="logo" align="right"><img src="./templates/Morpheus/images/logo_right.gif" width="125" height="69" /></td>
[/syntax]
Regards,
- Jorgen

Posted: Mon Sep 06, 2004 7:00 pm
by Ryan Norton
Jorg wrote:I have changed the layout as you suggested Ryan, can you check if it will work under IE ? This is the changed code:

[syntax="html"]
<td width="10%" height="69" class="logo" align="left"><a href="index.php"><img src="./templates/Morpheus/images/logo_left.gif" width="125" height="69" alt="wxWidgets Discussion Forum Forum Index" /></a></td>
<td width="80%" class="logo" align="center" valign="middle" style="color: #FFF; font-family: Arial;"><span style="font-size: 16px; font-weight: bold;">wxWidgets Discussion Forum</span><br /><span style="font-size: 14px;">Discussion forum for wxWidgets C++ / Python programming</span></td>
<td width="10%" height="69" class="logo" align="right"><img src="./templates/Morpheus/images/logo_right.gif" width="125" height="69" /></td>
[/syntax]
Regards,
- Jorgen
YAY!!!!

Now I don't have to scroll to the side to see everything :).

Thank you!!!

Posted: Mon Sep 06, 2004 7:02 pm
by Ryan Norton
tierra wrote:See, now if you spent half as much time fixing wx bugs, it'd be perfect :D
That would be approximately 100 seconds then.

Personally, I don't know about you, but if I spent that much time each day on wx bugs I don't think it would do a whole lot :lol:.