View posts since last visit marks posts as read Topic is solved

The Forum Rules, general FAQ and questions or comments about the forum are posted here.
Post Reply
radcapricorn
Experienced Solver
Experienced Solver
Posts: 70
Joined: Fri Nov 07, 2008 4:25 pm
Location: Saint-Petersburg, Russia

View posts since last visit marks posts as read

Post by radcapricorn » Thu Jan 22, 2009 11:49 am

Hello,

I've noticed this strange thing: if I log in on the forum, click on 'View posts since last visit' I see those posts well good. But if I close the browser and then log in again, I:

1. See only new posts that were made after me logging off (which is pretty understandable - they're indeed 'since last visit'), but:

2. All the posts that I viewed with previous query are marked as read, though I didn't read all of them. And that makes me track recent discussions by hand, which is a bit annoying.

Is it normal behavior?
win xp pro sp3/VS Express 2008/MinGW;
win Vista Ultimate/VS 2005;
Debian Lenny/gcc/cegcc-mingw32ce;
wxWidgets-2.8.9 w/wxWinCE;

upCASE
Site Admin
Site Admin
Posts: 3176
Joined: Mon Aug 30, 2004 6:55 am
Location: Germany, Cologne

Post by upCASE » Thu Jan 22, 2009 12:37 pm

Hi!
Yes, this behavior seems to be normal.

1. As you said, the posts for that are shown correctly. So it only displays new posts or responses that where made after you last visit.
2. The problem is that there is a session based cookie value that would handle this. When you log in again and search this would not be set, thus it can't be used to display the posts correctly. I'm not sure how to tackle this. However, after you visited the search page it should have been set and stored for the current session, so any subsequent searches should display correctly.
OS: OpenSuSE, Ubuntu, Win XP Pro
wx: svn
Compiler: gcc 4.5.1, VC 2008, eVC 4

"If it was hard to write it should be hard to read..." - the unknown coder
"Try not! Do. Or do not. There is no try." - Yoda

radcapricorn
Experienced Solver
Experienced Solver
Posts: 70
Joined: Fri Nov 07, 2008 4:25 pm
Location: Saint-Petersburg, Russia

Post by radcapricorn » Thu Jan 22, 2009 1:26 pm

Thanks for the explanation, I got it now.

I'd better check what I would get with different browsers (currently I use Google Chrome), maybe this'll get me additional input on this.
win xp pro sp3/VS Express 2008/MinGW;
win Vista Ultimate/VS 2005;
Debian Lenny/gcc/cegcc-mingw32ce;
wxWidgets-2.8.9 w/wxWinCE;

catalin
Moderator
Moderator
Posts: 1521
Joined: Wed Nov 12, 2008 7:23 am
Location: Romania

Post by catalin » Thu Jan 22, 2009 3:24 pm

Try it my way :)
If I login from the top-right corner of the page, then I get the behavior described by you.
But if you go to the login page, you have that check mark under the login fields - "Log me in automatically..." or something similar. If I check that one, when I come back I can also see old posts that I didn't get to read (Maybe that cookie is not removed this way?).
I use Firefox - don't think it matters.

I hope this helps.
Cheers

radcapricorn
Experienced Solver
Experienced Solver
Posts: 70
Joined: Fri Nov 07, 2008 4:25 pm
Location: Saint-Petersburg, Russia

Post by radcapricorn » Thu Jan 22, 2009 4:13 pm

Well, maybe it indeed doesn't matter, but I too have this checkbox set :-)
win xp pro sp3/VS Express 2008/MinGW;
win Vista Ultimate/VS 2005;
Debian Lenny/gcc/cegcc-mingw32ce;
wxWidgets-2.8.9 w/wxWinCE;

Post Reply