wxForum moved to new server

The Forum Rules, general FAQ and questions or comments about the forum are posted here.
Post Reply
jsheets
Earned a small fee
Earned a small fee
Posts: 22
Joined: Wed Oct 19, 2005 1:21 pm

wxForum moved to new server

Post by jsheets » Fri Jul 18, 2008 3:17 am

I have moved the forum to a new server and everything appears to be working properly.

This should end the bouts of downtime and might speed up the board a bit as it is a bit beefier server.
Last edited by jsheets on Fri Jul 18, 2008 5:55 pm, edited 1 time in total.

Jorg
Moderator
Moderator
Posts: 3971
Joined: Fri Aug 27, 2004 9:38 pm
Location: Delft, Netherlands
Contact:

Post by Jorg » Fri Jul 18, 2008 6:54 am

Hi Jason,

Thanks again. Now that you provided me with the new login data I will make a backup of the database and look from there if we can do some about the open issues for this forum. But as always my weekends are pretty unpredictable ;-)


- Jorgen
Forensic Software Engineer
Netherlands Forensic Insitute
http://english.forensischinstituut.nl/
-------------------------------------
Jorg's WasteBucket
http://www.xs4all.nl/~jorgb/wb

upCASE
Site Admin
Site Admin
Posts: 3176
Joined: Mon Aug 30, 2004 6:55 am
Location: Germany, Cologne

Post by upCASE » Fri Jul 18, 2008 7:45 am

Hi!
Seems like I should pay more attention as I didn't catch the server move... Having my newborn around kind of distracts me from focusing on important topics :)

Anyway: Thanks Jason!
Got the login data and when I find the time I'll do a backup as well. During the downtime I really feared data loss. Maybe it is time for a backup plan ;)
OS: OpenSuSE, Ubuntu, Win XP Pro
wx: svn
Compiler: gcc 4.5.1, VC 2008, eVC 4

"If it was hard to write it should be hard to read..." - the unknown coder
"Try not! Do. Or do not. There is no try." - Yoda

jsheets
Earned a small fee
Earned a small fee
Posts: 22
Joined: Wed Oct 19, 2005 1:21 pm

Post by jsheets » Fri Jul 18, 2008 1:09 pm

Congratulations on the new born, I also have one and totally understand ;).

Way more fun to play with baby.

Jorg
Moderator
Moderator
Posts: 3971
Joined: Fri Aug 27, 2004 9:38 pm
Location: Delft, Netherlands
Contact:

Post by Jorg » Sun Jul 20, 2008 11:20 am

Ok guys. I put a solid backup plan in place. I fiddled around some with Plesk, to get the scheduled backup to store on my local machine here, but failed. Since my machine is not always on I took a different approach ..

1) Everyday at 12:00 plesk backs up the forum to an FTP site of my provider (~75 Mb worth of archive)
2) I wrote a little python script to download all backup jobs from my provider FTP and delete them there
3) When my media system is switched on, every day at 22:00 that script is ran and after that a RAR cron job will archive it away

This should give us a pretty solid daily backup. And even when I forget to turn on my media PC for a while, I will retrieve the backup jobs on a later stage and archive them anyway.

This saves us at least the burden of manual backups and will make sure the last backup we have is daily-fresh

I will soon attend to the other chores for the wxForum but this one was the most important in my eyes.

- Jorgen
Forensic Software Engineer
Netherlands Forensic Insitute
http://english.forensischinstituut.nl/
-------------------------------------
Jorg's WasteBucket
http://www.xs4all.nl/~jorgb/wb

upCASE
Site Admin
Site Admin
Posts: 3176
Joined: Mon Aug 30, 2004 6:55 am
Location: Germany, Cologne

Post by upCASE » Mon Jul 21, 2008 7:41 am

Hi!
Jorg wrote:Ok guys. I put a solid backup plan in place.
Sounds solid indeed :)
If you can please do a one time backup of the forum sources as well.
Jorg wrote:I will soon attend to the other chores for the wxForum but this one was the most important in my eyes.
What are the remaining problems?
OS: OpenSuSE, Ubuntu, Win XP Pro
wx: svn
Compiler: gcc 4.5.1, VC 2008, eVC 4

"If it was hard to write it should be hard to read..." - the unknown coder
"Try not! Do. Or do not. There is no try." - Yoda

Jorg
Moderator
Moderator
Posts: 3971
Joined: Fri Aug 27, 2004 9:38 pm
Location: Delft, Netherlands
Contact:

Post by Jorg » Mon Jul 21, 2008 9:32 am

Hi upCASE,

Congratulations once again with your latest newborn.


Well there is the issue of SQL that is not UTF-8 or something so the search queries in foreign languages do not work. It is still puzzling to me why we need to do something about it, the text is displayed correctly in that language, maybe it requires a PHP change instead of DB change.

I also need to verify the backup. This means doing the following:
1) Lock it down
2) Backup the forum 10 mins later
3) Unlock it, post one test message and lock it
4) Perform a restore
5) Unlock it

The test message should be gone now. But before doing that I want to have a SQL dump of the DB itself in case something gets broken during restore so we can revert it by reapplying the SQL.

Oh and the source of the forum should also be inside the backup file(s) but it is kind of annoying to try to get the sources from the backed up file because it seems to be encrypted.

Other issues are, trying to make a side bar rather then a top bar. We can harvest more issues on the side, and make neat little icons for it.

Regards,
- Jorgen
Forensic Software Engineer
Netherlands Forensic Insitute
http://english.forensischinstituut.nl/
-------------------------------------
Jorg's WasteBucket
http://www.xs4all.nl/~jorgb/wb

Post Reply