wxRapid - A GUI editor

Do you like to promote your wxWidgets based application or component!? Post it here and let's see what the critics have to say. Also, if you found that ONE wx component the world needs to know about, put it here for future reference.
theWolf
Knows some wx things
Knows some wx things
Posts: 43
Joined: Wed May 18, 2005 12:27 am

Crash - possible path problems?

Post by theWolf » Thu Jun 23, 2005 4:34 pm

Hello Upcase,

Looks like you are making great progress. :D

I created a new project thus:
Project Options
Project output - Output creates a wxDialog
Code options - Generate XRC code (both radios checked)

Projectname: R1
Output path : c:\Projects\wx\rapid\r1
Author: theWolf

Selected "File|generate code"

CRASH :o

(Rapid created another folder under the one I had wanted
"c:\Projects\wx\rapid\r1\r1" - the errors reported before the program exited were; a general protection fault, and could not find the path to the header file r1.h)

I tried another attempt where I saved the project before selecting "File|generate code" - result was a single error: can't find path but no general protection fault. The program exited here too.


I hope this feedback helps. :)

Best regards.
______________
WxWidgets 2.6.1, .net 2003, Windows2000
Sometimes there's a lot of gravel around the gems. WxWidgets is a gem!

upCASE
Site Admin
Site Admin
Posts: 3176
Joined: Mon Aug 30, 2004 6:55 am
Location: Germany, Cologne

Post by upCASE » Fri Jun 24, 2005 6:55 am

Hi!
Thanks for your reply, I'll check that!

It's a bit strange though... Try the following:
1. Enter an output path
2. enter a projectname

wxRapid should then create a dir like PATH\PROJECTNAME and be able to work on it.
OS: OpenSuSE, Ubuntu, Win XP Pro
wx: svn
Compiler: gcc 4.5.1, VC 2008, eVC 4

"If it was hard to write it should be hard to read..." - the unknown coder
"Try not! Do. Or do not. There is no try." - Yoda

GeraldG
Experienced Solver
Experienced Solver
Posts: 85
Joined: Mon May 16, 2005 12:30 pm

Dont start on Win98

Post by GeraldG » Fri Jun 24, 2005 9:09 am

Hi upCASE,

very good project.
But the new version 0.9.1 doesnt show if started on Win98SE.
The process runs (pview) but no windows displayed (only short).

upCASE
Site Admin
Site Admin
Posts: 3176
Joined: Mon Aug 30, 2004 6:55 am
Location: Germany, Cologne

Post by upCASE » Fri Jun 24, 2005 9:31 am

Hi!
Checking right now (glad I got my Virtual PC :D). Hang on..

EDIT: You're right :shock: :shock: :shock:
Seems like a problem with the docking windows... I'm trying to get rid of it and put out a new version soon.
OS: OpenSuSE, Ubuntu, Win XP Pro
wx: svn
Compiler: gcc 4.5.1, VC 2008, eVC 4

"If it was hard to write it should be hard to read..." - the unknown coder
"Try not! Do. Or do not. There is no try." - Yoda

upCASE
Site Admin
Site Admin
Posts: 3176
Joined: Mon Aug 30, 2004 6:55 am
Location: Germany, Cologne

Post by upCASE » Fri Jun 24, 2005 10:53 am

Ok!
So, this was a really really weird bug...
It was in no way related to the docking windows like I thought at first, but to the code view windows. I used to create the window on startup and hide them for fast display later on if needed. Creating these windows in fact lead to not showing the main frame. To be honest I don't know why...

Anyway: I fixed that bug and tested it on Windows 98SE (Virtual PC). Cross fingers that it works now :D
New setup, as usual: http://www.upcase.de/stuff/wxRapid_setup.exe
OS: OpenSuSE, Ubuntu, Win XP Pro
wx: svn
Compiler: gcc 4.5.1, VC 2008, eVC 4

"If it was hard to write it should be hard to read..." - the unknown coder
"Try not! Do. Or do not. There is no try." - Yoda

GeraldG
Experienced Solver
Experienced Solver
Posts: 85
Joined: Mon May 16, 2005 12:30 pm

Post by GeraldG » Fri Jun 24, 2005 12:37 pm

Have tested the new version on win98se, it the same. Windows not visible.

have you packed the new .exe? Because .exe from yesterday:

wxRapid.exe 1.641.873, 23.06.2005, 10:49

upCASE
Site Admin
Site Admin
Posts: 3176
Joined: Mon Aug 30, 2004 6:55 am
Location: Germany, Cologne

Post by upCASE » Fri Jun 24, 2005 12:51 pm

Hi!
Oh, oh, oh.... stupid upCASE made a stupid mistake...

No, really, the setup is f** up. The whole thing won't generate a line of code, juts because I messed it up... Give me some time, I'll repack and update the setup. I'll post when I'm done.
OS: OpenSuSE, Ubuntu, Win XP Pro
wx: svn
Compiler: gcc 4.5.1, VC 2008, eVC 4

"If it was hard to write it should be hard to read..." - the unknown coder
"Try not! Do. Or do not. There is no try." - Yoda

upCASE
Site Admin
Site Admin
Posts: 3176
Joined: Mon Aug 30, 2004 6:55 am
Location: Germany, Cologne

Post by upCASE » Fri Jun 24, 2005 2:24 pm

Ok...
Now, I hope for the last time :D, an updated setup was uploaded. I just tested it, downloaded it to my Windows 98SE machine, installed it and it seems to work.

Have fun and a nice weekend!
OS: OpenSuSE, Ubuntu, Win XP Pro
wx: svn
Compiler: gcc 4.5.1, VC 2008, eVC 4

"If it was hard to write it should be hard to read..." - the unknown coder
"Try not! Do. Or do not. There is no try." - Yoda

GeraldG
Experienced Solver
Experienced Solver
Posts: 85
Joined: Mon May 16, 2005 12:30 pm

Post by GeraldG » Fri Jun 24, 2005 3:24 pm

Yes, now it works on Win98 too. Thanks

upCASE
Site Admin
Site Admin
Posts: 3176
Joined: Mon Aug 30, 2004 6:55 am
Location: Germany, Cologne

Post by upCASE » Fri Jun 24, 2005 3:37 pm

GeraldG wrote:Yes, now it works on Win98 too. Thanks
Phew... :D
Glad to hear that!

Same procedure as every friday: Off for the weekend. Feel free to post your comments, I may observe them, but it's more likely that I won't answer till monday and bugfixes won't be released over the weekend.
As I'm on a trip to London next week, a new version is more likely to come out next month.
OS: OpenSuSE, Ubuntu, Win XP Pro
wx: svn
Compiler: gcc 4.5.1, VC 2008, eVC 4

"If it was hard to write it should be hard to read..." - the unknown coder
"Try not! Do. Or do not. There is no try." - Yoda

Chr
Earned some good credits
Earned some good credits
Posts: 115
Joined: Tue May 31, 2005 2:17 pm

Post by Chr » Fri Jun 24, 2005 7:23 pm

on the right side, down, the control in which you can set the properties of a e.g. button. Which control is it??
wxWidgets is nice

jms
Experienced Solver
Experienced Solver
Posts: 54
Joined: Wed Sep 29, 2004 6:37 am
Location: Finland

Post by jms » Sat Jun 25, 2005 12:40 pm

That would be wxPropertyGrid.

Game_Ender
Knows some wx things
Knows some wx things
Posts: 45
Joined: Wed Jun 15, 2005 5:47 pm

Post by Game_Ender » Mon Jul 25, 2005 5:21 pm

How is this project comming?

upCASE
Site Admin
Site Admin
Posts: 3176
Joined: Mon Aug 30, 2004 6:55 am
Location: Germany, Cologne

Post by upCASE » Tue Jul 26, 2005 6:12 am

Hi!
At the moment I'm pretty busy with other things and don't have the time for developing it any further. When there's time, there will be an update. There still is much on my todo list :D
OS: OpenSuSE, Ubuntu, Win XP Pro
wx: svn
Compiler: gcc 4.5.1, VC 2008, eVC 4

"If it was hard to write it should be hard to read..." - the unknown coder
"Try not! Do. Or do not. There is no try." - Yoda

Post Reply