wx-config --version fails

If you are using the main C++ distribution of wxWidgets, Feel free to ask any question related to wxWidgets development here. This means questions regarding to C++ and wxWidgets, not compile problems.
Post Reply
snowsquirrel
Earned a small fee
Earned a small fee
Posts: 19
Joined: Thu Dec 30, 2004 11:37 pm

wx-config --version fails

Post by snowsquirrel » Sat Jan 08, 2005 12:29 am

wx-config --version fails saying that there is a syntax error before ; at line 151. I using wx 2.5.3.

On solaris 2.8. I suspect the problem is an old version of /bin/sh. Changing this to /bin/bash fixed the problem.

It this was a bad thing to do, let me know what the right thing to do was.

Thanks,

~S

User avatar
Ryan Norton
Moderator
Moderator
Posts: 1319
Joined: Mon Aug 30, 2004 6:01 pm

Post by Ryan Norton » Wed Feb 09, 2005 8:02 am

Nah - there were several reports after a huge wx-config change in 2.5.3+ that it broke compatability with non-bash shells...

Not sure if its fixed though, you might try a mail to wx-dev if it still isnt in CVS HEAD
[Mostly retired moderator, still check in to clean up some stuff]

snowsquirrel
Earned a small fee
Earned a small fee
Posts: 19
Joined: Thu Dec 30, 2004 11:37 pm

Post by snowsquirrel » Wed Feb 09, 2005 4:48 pm

it is fixed in cvs.

Post Reply