No tooltips - Bug? Topic is solved

If you are using the main C++ distribution of wxWidgets, Feel free to ask any question related to wxWidgets development here. This means questions regarding to C++ and wxWidgets, not compile problems.
Post Reply
Vexator
I live to help wx-kind
I live to help wx-kind
Posts: 187
Joined: Sun Jan 30, 2005 2:50 pm
Location: Heidelberg, Germany

No tooltips - Bug?

Post by Vexator » Sat Jun 03, 2006 9:50 am

if i have more than one toolbar in my app, only the tooltips of the first one are displayed. is this a known bug? this does only happen to tooltips given as an argument in the wxtoolbar::addtool() functions; if i set a tooltip for a control manually before i add it to the toolbar, it works.
Windows 7 Pro
Visual Studio 2010
wxWidgets 2.9.3

benedicte
wxWorld Domination!
wxWorld Domination!
Posts: 1409
Joined: Wed Jan 19, 2005 3:44 pm
Location: Paris, France

Post by benedicte » Sat Jun 03, 2006 6:46 pm

What are you using to have multiple toolbars (wxAUI, WXIFM, ...)?

What identifies the one you call "first one"? The creation order? The way it is attached to the frame?
Could you post some code?

Vexator
I live to help wx-kind
I live to help wx-kind
Posts: 187
Joined: Sun Jan 30, 2005 2:50 pm
Location: Heidelberg, Germany

Post by Vexator » Sat Jun 03, 2006 11:50 pm

i use wxaui. the "first one" is the mainframe's toolbar. the other ones are toolbars of wxaui panes.

in my viewport class:

Code: Select all

void Viewport3D::SetupToolbar()
{
ToolsPanel = new wxPanel( this, wxID_ANY, wxDefaultPosition, wxSize(300, 25) );
Tools = new wxToolBar( ToolsPanel, wxID_ANY, wxDefaultPosition, wxDefaultSize, wxTB_FLAT | wxTB_NODIVIDER );
...
Tools->Realize();
}
and then, whenever i need a new viewport:

Code: Select all

Viewport3D *viewport = new Viewport3D( this, GlobalData.get() );
wxString Name = wxString::Format( "3D Viewport #%i", viewport->GetId() );
Manager.AddPane( viewport, wxPaneInfo().Name(Name).Caption(_("3D Viewport")).Float().
FloatingPosition(ClientToScreen(wxPoint(20, 20))).FloatingSize(wxSize(400, 300)).MinSize(wxSize(400, 300)).DestroyOnClose(true) );
i realized that it only happens when the pane is initlialized floating. the tooltips work until i have docked the viewport once.
Windows 7 Pro
Visual Studio 2010
wxWidgets 2.9.3

lowjoel
Moderator
Moderator
Posts: 1511
Joined: Sun Jun 19, 2005 11:37 am
Location: Singapore
Contact:

Post by lowjoel » Sun Jun 04, 2006 2:01 pm

I think you should have a go at the wxAUI forum... I've not added multiple toolbars to floatable panes yet. Maybe Ben will help.

Post Reply