building wxGTK2.4.2

If you are using the main C++ distribution of wxWidgets, Feel free to ask any question related to wxWidgets development here. This means questions regarding to C++ and wxWidgets, not compile problems.
Post Reply
vsp
Knows some wx things
Knows some wx things
Posts: 35
Joined: Mon Feb 21, 2005 12:52 pm

building wxGTK2.4.2

Post by vsp » Thu Apr 06, 2006 7:36 am

hi

i am trying to port my program with Red Linux 64bit AMD machine and my compiler version is " gcc version 3.4.4 20050721 (Red Hat 3.4.4-2)" i have installed wxWindows2.4.2 with gtk2.0. when i tried to build the exe i am getting the following errors
/home/downloads/wxGTK-2.4.2/lib/libwx_gtk2-2.4.so: undefined reference to `_gtk_accel_group_detach'
/home/downloads/wxGTK-2.4.2/lib/libwx_gtk2-2.4.so: undefined reference to `_gtk_accel_group_attach'
/home/downloads/wxGTK-2.4.2/lib/libwx_gtk2-2.4.so: undefined reference to `_gtk_rc_context_get_default_font_name'
collect2: ld returned 1 exit status

could u give me some solutions to resolve these errors and build my exe.

thank u

DavidHart
Site Admin
Site Admin
Posts: 4002
Joined: Thu Jan 12, 2006 6:23 pm
Location: IoW, UK

Post by DavidHart » Thu Apr 06, 2006 9:17 am

Hi,

wxGTK-2.4.2 was the first version that tried to work with gtk2, but it was considered experimental and likely not to work properly. I didn't risk it myself.

Do you have some compelling reason for using 2.4.2? If so, I suggest you use gtk1.2 (on recent distros the devel files for this are usually not installed by default, but they are still available: for example on Fedora core 3 I needed gtk+-devel-1.2.10-33.i386.rpm & glib-devel-1.2.10-15.i386.rpm).

Otherwise upgrade to 2.6.?, with which gtk2 will work.

Regards,

David

Post Reply