Issues with wx 2.9.5

If you are using the main C++ distribution of wxWidgets, Feel free to ask any question related to wxWidgets development here. This means questions regarding to C++ and wxWidgets, not compile problems.
Post Reply
spectrum
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 207
Joined: Sat Jul 21, 2007 12:17 pm

Issues with wx 2.9.5

Post by spectrum » Wed Sep 18, 2013 8:00 am

Dear All,
i downloaded and compiled this version of wxwidgets to build a simple terminal application.

I have 2 issues:
1) I have a wxFrame with some panels, in one panel i have a wxControl that contains a gtk vte terminal. The terminal is shown with no width, whatever width i set.
This could also be an issue on libvte-2.90 of course (i had to use now libvte-2.9 for gtk-3 instead of libvte-0.0).
snapshot1.png
snapshot1.png (6.11 KiB) Viewed 1005 times
2) wxPropertyGrid background is black, instead of the default white.

[attachment=0]snapshot2.png[/attachment

I attach the images of the issues.

Many thanks.
Angelo
Attachments
snapshot2.png
snapshot2.png (17.09 KiB) Viewed 1005 times
spectrum

User avatar
doublemax
Moderator
Moderator
Posts: 15173
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: Issues with wx 2.9.5

Post by doublemax » Wed Sep 18, 2013 1:14 pm

i had to use now libvte-2.9 for gtk-3 instead of libvte-0.0
Does that mean you were using wxWidgets for GTK3? I don't use Linux, but AFAIK that's still in early stage of development. Try using GTK2.

And in any case: Check if the wxWidgets samples are working correctly.
Use the source, Luke!

spectrum
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 207
Joined: Sat Jul 21, 2007 12:17 pm

Re: Issues with wx 2.9.5

Post by spectrum » Wed Sep 18, 2013 1:52 pm

wxWidget 2.9.5 builds with gtk3 as default, so i supposed it mainly works since is near to the 3.0 milestone.
Sure, i am moving to gtk2 for now. Will report the issue to the trac.

Regards,
spec
spectrum

spectrum
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 207
Joined: Sat Jul 21, 2007 12:17 pm

Re: Issues with wx 2.9.5

Post by spectrum » Wed Sep 18, 2013 6:41 pm

spectrum

Post Reply