Asserts in 2.9.4 release ? Topic is solved

If you are using the main C++ distribution of wxWidgets, Feel free to ask any question related to wxWidgets development here. This means questions regarding to C++ and wxWidgets, not compile problems.
Post Reply
Lech Kozarski
Earned a small fee
Earned a small fee
Posts: 20
Joined: Sat Nov 26, 2011 3:15 pm

Asserts in 2.9.4 release ?

Post by Lech Kozarski » Thu Sep 13, 2012 9:35 am

I do not know how to solve the problem with these asserts in 2.9.4
1. I compiled wxWidgets ( mingw32-make -f makefile.gcc BUILD=release SHARED=0 MONOLITHIC=1 UNICODE=1 )
2. When i try add wxAUImanager+AUInotebook+panels i have asserts when i close my program :
/src/comman/wincmn.cpp(468):assert: GetEventHandler()==this failed in wxWindowsBase....
=========== NEXT STEP ======
3. I make again wxWidgets with this : http://forums.wxwidgets.org/viewtopic.p ... 7&p=140532
4. I compiled wxWidgets with DEBUG_FLAG=0 and in my project I have : #defines: wxDEBUG_LEVEL=0
Results:
When I need wxPDFdocuments and wxFreeChart and wxFTP ... I have asserts about AUI and wxThreads
when all asserts disable then I can not works with this librarys becose I have message about ... undifined reference to wxTheAssertHandler ..

How do I perform the operation wxWidgets ( compile with Assert ) but not display them in the release version

Need help please?

User avatar
doublemax
Moderator
Moderator
Posts: 14898
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: Asserts in 2.9.4 release ?

Post by doublemax » Thu Sep 13, 2012 10:23 am

Compiling with DEBUG_FLAG=0 on the command line should have worked. You probably have to pass that when building the wx libraries and also when you build your own application.

However, even if some asserts are harmless, the one you posted looks more serious and you should try to fix the reason for the assert rather than suppressing it.
Use the source, Luke!

Lech Kozarski
Earned a small fee
Earned a small fee
Posts: 20
Joined: Sat Nov 26, 2011 3:15 pm

Re: Asserts in 2.9.4 release ?

Post by Lech Kozarski » Thu Sep 13, 2012 10:54 am

You're right, but even when I do a new test project with AUIManager+AUI notebook+some imagepanels without any other libraries then I have this error too.
Surely all content is wxWidgets components. Maybe in AUI something is wrong?

User avatar
doublemax
Moderator
Moderator
Posts: 14898
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: Asserts in 2.9.4 release ?

Post by doublemax » Thu Sep 13, 2012 11:27 am

Surely all content is wxWidgets components. Maybe in AUI something is wrong?
Does it also happen when you build and run the "aui" sample?
Use the source, Luke!

Lech Kozarski
Earned a small fee
Earned a small fee
Posts: 20
Joined: Sat Nov 26, 2011 3:15 pm

Re: Asserts in 2.9.4 release ?

Post by Lech Kozarski » Thu Sep 13, 2012 11:52 am

Here is link for my test project with source file.

https://dl.dropbox.com/u/28560522/_error/Test_AUI.rar

Maybe someone will see this and will help in finding the error

Thanks

User avatar
doublemax
Moderator
Moderator
Posts: 14898
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: Asserts in 2.9.4 release ?

Post by doublemax » Thu Sep 13, 2012 12:13 pm

http://forums.wxwidgets.org/viewtopic.php?f=1&t=32533
http://forums.wxwidgets.org/viewtopic.php?f=30&t=32138

Bottom line is: You need to call UnInit() on your wxAuiManager instance in the wxFrame dtor.
Use the source, Luke!

PB
Part Of The Furniture
Part Of The Furniture
Posts: 2438
Joined: Sun Jan 03, 2010 5:45 pm

Re: Asserts in 2.9.4 release ?

Post by PB » Thu Sep 13, 2012 1:20 pm

I wonder why this patch has not been applied already.

woser
Earned a small fee
Earned a small fee
Posts: 18
Joined: Thu Nov 18, 2010 8:32 am

Re: Asserts in 2.9.4 release ?

Post by woser » Thu Sep 13, 2012 4:54 pm

It's strange for me too, why ??

User avatar
doublemax
Moderator
Moderator
Posts: 14898
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: Asserts in 2.9.4 release ?

Post by doublemax » Thu Sep 13, 2012 5:19 pm

If this patch is important to you, you can easily apply it to your local copy.
It's strange for me too, why ??
Because Vadim is pretty much the only one who's doing this and he already has around 80-90% of all wx development on his shoulders - next to his daytime job.
Use the source, Luke!

Lech Kozarski
Earned a small fee
Earned a small fee
Posts: 20
Joined: Sat Nov 26, 2011 3:15 pm

Re: Asserts in 2.9.4 release ?

Post by Lech Kozarski » Thu Sep 13, 2012 5:38 pm

Is this important to me ..????

Wow I am first with AUI asserts error so... WELCOME

I think when we have problems we must try resolve it.

So thanks

User avatar
doublemax
Moderator
Moderator
Posts: 14898
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: Asserts in 2.9.4 release ?

Post by doublemax » Thu Sep 13, 2012 5:44 pm

Wow I am first with AUI asserts error so... WELCOME
No, see my post further above.
Use the source, Luke!

Lech Kozarski
Earned a small fee
Earned a small fee
Posts: 20
Joined: Sat Nov 26, 2011 3:15 pm

Re: Asserts in 2.9.4 release ?

Post by Lech Kozarski » Thu Sep 13, 2012 9:02 pm

So after added patch AUI and again compile wxWidgets the AUI works fine ( without asserts )
And wxPDFdocuments works fine.
So ... thanks for help.
ps. How i can make this post [SOLVED] ? ........... or Admin must do it ?

Thanks again

Auria
Site Admin
Site Admin
Posts: 6695
Joined: Thu Sep 28, 2006 12:23 am
Contact:

Re: Asserts in 2.9.4 release ?

Post by Auria » Thu Sep 13, 2012 10:01 pm

To mark a post solved, click on the green check icon on top of the post that helped you most
"Keyboard not detected. Press F1 to continue"
-- Windows

Post Reply