wxString already defined in dll Topic is solved

If you are using the main C++ distribution of wxWidgets, Feel free to ask any question related to wxWidgets development here. This means questions regarding to C++ and wxWidgets, not compile problems.
mael15
Super wx Problem Solver
Super wx Problem Solver
Posts: 460
Joined: Fri May 22, 2009 8:52 am
Location: Bremen, Germany

Post by mael15 » Fri Oct 29, 2010 11:58 am

hi andre,

i finally found the mistake, my preprocessor symbols where messed up. everything works not with only _DEBUG and WXUSINGDLL. i did not really understand preprocessor symbols before, so i just tried different things that i found on the internet without knowing what i was doing.

i also built wx from the standard wx_dll.dsw file, not the special one from wx291_msw_vc10.zip from one of my earlier posts. maybe that was also important.

about your last post, the preprocessor symbols in the wx build included DLL_EXPORTS, so everything was fine there. i just did not use the dll version of wx in my project.

thank you VERY much for taking the time to help me and being patient with my half-knowledge (is this a word in english, we use it in German).

Post Reply