I have some problems with GTK when displaying the window

If you are using the main C++ distribution of wxWidgets, Feel free to ask any question related to wxWidgets development here. This means questions regarding to C++ and wxWidgets, not compile problems.
Post Reply
yangyuebin
In need of some credit
In need of some credit
Posts: 4
Joined: Fri Jul 23, 2010 7:39 am

I have some problems with GTK when displaying the window

Post by yangyuebin » Fri Jul 23, 2010 8:04 am

Hey,guys!
I have some problems in GTK when displaying the window( call the function wxWindow::Show() )!
I put a Dialog on the right side of the screen , And hide it at first.
For test only,I set it shown and hidden again and again.But the Dialog is always at the center of the screen,why?

Now I use wxWindow::Move() before displaying the Dialog.It seems everyting goes OK,but when I make the default position on the left side of the screen,the problem comes up again!

could someone help me?

At the end,thanks for reading.My English is poor,I hope that you can understand it.Thank you!!!

Jorg
Moderator
Moderator
Posts: 3971
Joined: Fri Aug 27, 2004 9:38 pm
Location: Delft, Netherlands
Contact:

Post by Jorg » Fri Jul 23, 2010 12:30 pm

Long shot, but Compiz will manage your windows for you and positioning is kind of random depending on what spot is available on your desktop.

I am not sure, but if you disable Visual Effects in appearance to use the standard gnome window manager, you might see that your positioning does work

With regards,
- Jorgen
Forensic Software Engineer
Netherlands Forensic Insitute
http://english.forensischinstituut.nl/
-------------------------------------
Jorg's WasteBucket
http://www.xs4all.nl/~jorgb/wb

yangyuebin
In need of some credit
In need of some credit
Posts: 4
Joined: Fri Jul 23, 2010 7:39 am

Post by yangyuebin » Sat Jul 24, 2010 2:03 pm

Jorg wrote:Long shot, but Compiz will manage your windows for you and positioning is kind of random depending on what spot is available on your desktop.

I am not sure, but if you disable Visual Effects in appearance to use the standard gnome window manager, you might see that your positioning does work

With regards,
- Jorgen
Thanks for your reply!!!
I am using the system is ubunt10.04, and I also really disable the Desktop Effects.

Auria
Site Admin
Site Admin
Posts: 6695
Joined: Thu Sep 28, 2006 12:23 am
Contact:

Post by Auria » Sat Jul 24, 2010 11:09 pm

Can you show some minimal code that demonstrates the problem?
"Keyboard not detected. Press F1 to continue"
-- Windows

Post Reply