wxODBC and wxwidgets 2.9 > 3..... Topic is solved

If you are using the main C++ distribution of wxWidgets, Feel free to ask any question related to wxWidgets development here. This means questions regarding to C++ and wxWidgets, not compile problems.
Post Reply
JPlaroche
Earned some good credits
Earned some good credits
Posts: 131
Joined: Fri Dec 09, 2005 4:58 pm
Contact:

wxODBC and wxwidgets 2.9 > 3.....

Post by JPlaroche » Wed Mar 11, 2009 12:37 pm

french

pouvez vous me donnez une Idée ,

probleme ,

je veux garder WXODBC avec les sources de 2.8

donc j'ai un projet wx_ODBC
projet ms importer wx_odbc.dsp sous windows
je travail avec code::blocks

je veux me servir de la lib sous 2.9 avec les sources
db.h
dbkeyg.h
dbtable.h
et mes libwx_odbc.a libwx_odbcu.a
dans un folder ODBC

est-ce que je peux et qu'en pensez-vous

===============================================
can you give me an Idea,

probleme,

I want to keep WXODBC with the sources of 2,8

therefore I have a project wx_ODBC project ms to import wx_odbc. dsp under Windows I work with code: : blocks

I want to use the lib under 2,9 with the sources db.h dbkeyg.h dbtable.h and my libwx_odbc. has libwx_odbcu.
has in a folder ODBC

I can and that in you think
apprendre et developper en C++ des sub routine interfac� HIM et BD pour validation acquis
Jean-Pierre

project define DB descripteur idem IBM400
http://www.ombrebleu.com/wxsrc/src/

computerquip
Experienced Solver
Experienced Solver
Posts: 72
Joined: Fri Feb 20, 2009 7:13 pm
Location: $(#wx)\src

Post by computerquip » Wed Mar 11, 2009 1:38 pm

It sounds like your wanting features from one version of wxWidgets but you want to use the main body of another. If thats the case, I think it safe to copy the features and integrate them yourself into the version of wxWidgets that you want. Then just recompile.

JPlaroche
Earned some good credits
Earned some good credits
Posts: 131
Joined: Fri Dec 09, 2005 4:58 pm
Contact:

Post by JPlaroche » Wed Mar 11, 2009 1:45 pm

computerquip wrote:It sounds like your wanting features from one version of wxWidgets but you want to use the main body of another. If thats the case, I think it safe to copy the features and integrate them yourself into the version of wxWidgets that you want. Then just recompile.

merci,

oui je veux utiliser wxwidgets 2.9
mais wxodbc n'est plus pris encharge,

je voudrais continuer à utiliser juste wxODBC avec la nouvelle version

donc j'ai pensé utiliser les *.h et les lib construite avec 2.8.8 ODBC
en les intégrant a 2.9


thank you,

yes I want to use wxwidgets 2,8.8 but wxodbc not more is taken encharge,

I would want to continue to use just wxODBC with the new version

therefore I thought to use the *.a and the libxxodbc.a works with 2,8.8 ODBC while the integrating has 2.9
apprendre et developper en C++ des sub routine interfac� HIM et BD pour validation acquis
Jean-Pierre

project define DB descripteur idem IBM400
http://www.ombrebleu.com/wxsrc/src/

User avatar
tierra
Site Admin
Site Admin
Posts: 1343
Joined: Sun Aug 29, 2004 7:14 pm
Location: Salt Lake City, Utah, USA
Contact:

Post by tierra » Wed Mar 11, 2009 7:44 pm

The reason that wxODBC was removed from wxWidgets in 2.9+ is because it was supposedly broken with changes to wxString in 2.9, and no-one was willing to spend the time to fix it, so it's actually very unlikely that you will be able to use wxODBC with wxWidgets 2.9+. You can't just mix and match libraries like that.

JPlaroche
Earned some good credits
Earned some good credits
Posts: 131
Joined: Fri Dec 09, 2005 4:58 pm
Contact:

Post by JPlaroche » Wed Mar 11, 2009 9:54 pm

tierra wrote:The reason that wxODBC was removed from wxWidgets in 2.9+ is because it was supposedly broken with changes to wxString in 2.9, and no-one was willing to spend the time to fix it, so it's actually very unlikely that you will be able to use wxODBC with wxWidgets 2.9+. You can't just mix and match libraries like that.

thank you :oops:

I accept your remark

I will look for a lib to communicate with AS400 :(
apprendre et developper en C++ des sub routine interfac� HIM et BD pour validation acquis
Jean-Pierre

project define DB descripteur idem IBM400
http://www.ombrebleu.com/wxsrc/src/

philip0425
In need of some credit
In need of some credit
Posts: 7
Joined: Mon Mar 09, 2009 6:55 am

Post by philip0425 » Thu Mar 12, 2009 5:32 pm

I face the same problem. I also hope to keep wxODBC in the future version before a better replacement is found. Also the current package lack of a report writer. It's a pity.

JPlaroche
Earned some good credits
Earned some good credits
Posts: 131
Joined: Fri Dec 09, 2005 4:58 pm
Contact:

Post by JPlaroche » Thu Mar 12, 2009 7:24 pm

philip0425 wrote:I face the same problem. I also hope to keep wxODBC in the future version before a better replacement is found. Also the current package lack of a report writer. It's a pity.
je travail avec AS400 V5R4 and V6R1

bonjour j'ai trouvé une lib qui marche parfaitement avec
DB2 etc.... je suis en plein TEST et les temps de réponse sont époustouflant

OTL

http://otl.sourceforge.net/
http://users.skynet.be/fb336405/wxOTL/index.html

elle est très active et du même gabarit que STL
j'ai couplé avec la gestion décimal 128 bit que je vais mettre à jour sur mon site


Hello I found a lib that perfectly walks with DB2 etc. ... I am in the middle of the TEST and the response times are
staggering

OTL

http://otl.sourceforge.net/
http://users.skynet.be/fb336405/wxOTL/index.html
she is very active and same caliber that STL I coupled with the decimal management 128 bits that I will update on my site
apprendre et developper en C++ des sub routine interfac� HIM et BD pour validation acquis
Jean-Pierre

project define DB descripteur idem IBM400
http://www.ombrebleu.com/wxsrc/src/

Quentin
Knows some wx things
Knows some wx things
Posts: 42
Joined: Wed Jul 07, 2010 9:47 am

Post by Quentin » Fri Nov 12, 2010 2:44 pm

Hi,

I know that the topic is quite old now, but I have a question regarding:
tierra wrote:it's actually very unlikely that you will be able to use wxODBC with wxWidgets 2.9+.
So I won't be able to connect to a database within my wxWidgets program at all :?:

Did someone use wxOTL (it was mentioned above) in wxWidgets 2.9.1 :?:
Image

User avatar
tierra
Site Admin
Site Admin
Posts: 1343
Joined: Sun Aug 29, 2004 7:14 pm
Location: Salt Lake City, Utah, USA
Contact:

Post by tierra » Sun Nov 14, 2010 11:34 pm

Quentin wrote:So I won't be able to connect to a database within my wxWidgets program at all
Well, you have two options.

First, you could volunteer to update the wxODBC library to work with wxWidgets 2.9, and if it was to be re-included, it would absolutely require a full commitment on your part to continue maintenance on it as no-one else will - being the reason it was removed in the first place (there were several months of making announcements about it in the usual wxWidgets communication channels, no-one spoke up).

The second option (and one I would recommend) is to migrate your existing wxODBC calls to use an alternative ODBC library such as DatabaseLayer, SOCI, or wxDba. Those are just a few of the libraries I can think of. I'm sure there's a bunch more you could use instead as well.

Post Reply