wxConnection cannot stop advise

If you are using the main C++ distribution of wxWidgets, Feel free to ask any question related to wxWidgets development here. This means questions regarding to C++ and wxWidgets, not compile problems.
RP__
Earned some good credits
Earned some good credits
Posts: 124
Joined: Tue Jan 20, 2015 5:53 pm

wxConnection cannot stop advise

Postby RP__ » Mon Jul 17, 2017 10:09 am

Hello everybody,

It appears that when I use wxServer and wxClient on the same system, using TCP, I cannot always stop the Advise from the client.
This also happens when I am using the sample. In fact, I always use the client sample to run with my server.
When I use DDE, there are no issues and I can stop the Advise just fine, no crashes what so ever.

The first time I press StopAdvise, nothing happens. Then the second time, I get this:
Image

The server is allowed access through the firewall, so it's not a security issue.

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 1800
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: wxConnection cannot stop advise

Postby ONEEYEMAN » Mon Jul 17, 2017 6:22 pm

Hi,
How do you know you can't stop it?

Thank you.

RP__
Earned some good credits
Earned some good credits
Posts: 124
Joined: Tue Jan 20, 2015 5:53 pm

Re: wxConnection cannot stop advise

Postby RP__ » Tue Jul 18, 2017 6:31 am

I start it, and then when I try to stop it, my OnStopAdvise function isn't called.
There's a log line in OnStopAdvise which logs the unique ID of the connection as well as it request.
This log line never appears. The same happens with the server sample! The OnStopAdvise line is never logged.

EDIT:
It seems that once I start my server, then stop and start the server sample, the issue occurs.
When I first run the sample, I can stop advising.


Return to “C++ Development”

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 3 guests