Search found 79 matches

by Rocketmagnet
Sat Dec 08, 2007 11:09 pm
Forum: Component Writing
Topic: Customising wxFileDialog
Replies: 1
Views: 775

update...

I've just discovered wxGenericFileDialog, which might be just what I need. However, I don't seem to be able to find any documentation on it, and can't get it to work.

Any ideas?

hugo
by Rocketmagnet
Sat Dec 08, 2007 9:13 pm
Forum: Component Writing
Topic: Customising wxFileDialog
Replies: 1
Views: 775

Customising wxFileDialog

Hi all, I would like to use a file dialog in my applications. I am basically happy with the standard wxFileDialog, but I would like to add some more controls to it. One way I could do it is to totally re-create the file dialog by adding controls to a standard wxDialog, and add my own controls too. B...
by Rocketmagnet
Sat Jul 28, 2007 7:10 pm
Forum: C++ Development
Topic: OpenGL Textures + wxWidgets
Replies: 20
Views: 2768

Couldn't you just enable textures, disable color material, and glColor4f(1,1,1,1) ? AFAIK that should work
That's what I thought. And that's what I was doing, but now it seems to demand that too. I dunno, maybe I did something else which now requires those commands too?

hugo
by Rocketmagnet
Sat Jul 28, 2007 3:45 pm
Forum: C++ Development
Topic: OpenGL Textures + wxWidgets
Replies: 20
Views: 2768

Crikey! I spent hours last night tearing my code apart to work out what was the difference between your code and mine. Eventually, I think the problem came down to two different things: 1: Having two wxGlCanvases open, and trying to setup textures for the first one just after the second one had been...
by Rocketmagnet
Fri Jul 27, 2007 11:27 pm
Forum: C++ Development
Topic: OpenGL Textures + wxWidgets
Replies: 20
Views: 2768

Huh!

Would you adam n' believe it? It worked. Thanks mate, now I've got something to start exploring. I'll post the reason here when I've found it.

Hugo
by Rocketmagnet
Fri Jul 27, 2007 6:04 pm
Forum: C++ Development
Topic: OpenGL Textures + wxWidgets
Replies: 20
Views: 2768

XP Pro SP1, wx 2.8.4, VS NET 2003, NVidia Graphics
Awesome, me too!
by Rocketmagnet
Fri Jul 27, 2007 5:38 pm
Forum: C++ Development
Topic: OpenGL Textures + wxWidgets
Replies: 20
Views: 2768

thanks mate. I'll try this when I get home.

I assume you've tested this code, and see the texture appear on the screen? Also, what system are you using?
by Rocketmagnet
Fri Jul 27, 2007 12:41 pm
Forum: C++ Development
Topic: OpenGL Textures + wxWidgets
Replies: 20
Views: 2768

Can anyone modify the Cube example to add textures? I have tried, but the textures just don't show. I would be very interested to see if anyone else can do it.

BTW, I'm running Windows XP, with wx 2.8.4

Many thanks

hugo
by Rocketmagnet
Fri Jul 27, 2007 1:11 am
Forum: C++ Development
Topic: OpenGL Textures + wxWidgets
Replies: 20
Views: 2768

Thanks RB, but that doesn't address the question of why wxGlCanvas doesn't seem to be displaying textures at all.
by Rocketmagnet
Thu Jul 26, 2007 11:51 pm
Forum: C++ Development
Topic: OpenGL Textures + wxWidgets
Replies: 20
Views: 2768

Auria,

I tried the example you suggested, but I couldn't get it to compile. I'll be honest, compilers scare the willies outta me.
I got about one million bizzare errors from gl.h, so I'm guessing the compiler settings are wrong. I used exactly the same settings as the wx cube example.

hugo
by Rocketmagnet
Thu Jul 26, 2007 11:33 pm
Forum: C++ Development
Topic: OpenGL Textures + wxWidgets
Replies: 20
Views: 2768

I just tried modifying the Cube example to add textures. No luck...
by Rocketmagnet
Thu Jul 26, 2007 12:22 am
Forum: C++ Development
Topic: OpenGL Textures + wxWidgets
Replies: 20
Views: 2768

I'm having the same problem. Interestingly, the textures used to work, but recently stopped working. I think it may have been when I switched from wxWidgets 2.6.3 to 2.8.4.

I'm pretty sure I didn't touch the rendering code in that time.

Has anyone else experienced this?

Hugo
by Rocketmagnet
Sun Aug 20, 2006 3:20 pm
Forum: C++ Development
Topic: wxString unresolved external symbol
Replies: 1
Views: 474

Sorry, I posted this in wrong forum. Can I move it?
by Rocketmagnet
Sun Aug 20, 2006 3:09 pm
Forum: C++ Development
Topic: wxString unresolved external symbol
Replies: 1
Views: 474

wxString unresolved external symbol

Hi there, Just installed wxWidgets on a new machine, and trying to get my old project to compile again. But I'm having some difficulties. When it links... unresolved external symbol "private: void __thiscall wxString::InitWith(char const *,unsigned int,unsigned int)" referenced in function "public: ...
by Rocketmagnet
Sun Aug 20, 2006 2:57 pm
Forum: C++ Development
Topic: wxzlib.lib changed to zlib.lib ?
Replies: 1
Views: 679

wxzlib.lib changed to zlib.lib ?

Hi there, I've used wxWidgets for quite some time now. But I just installed it on a new machine, compiled it, then tried to compile one of the samples. It came up with an error. The linker could not find the following libraries: wxtiffd.lib wxjpegd.lib wxpngd.lib wxzlibd.lib wxregexd.lib wxexpatd.li...