Search found 84 matches

by eriX
Thu Dec 15, 2011 5:30 am
Forum: wxDev-C++
Topic: cannot find -lwregex // wxWidgets 2.9.2 DevPack
Replies: 17
Views: 8106

Re: cannot find -lwregex // wxWidgets 2.9.2 DevPack

The warnings are the same as above.

Sqlite is linked in linker options.
by eriX
Wed Dec 14, 2011 6:09 pm
Forum: wxDev-C++
Topic: cannot find -lwregex // wxWidgets 2.9.2 DevPack
Replies: 17
Views: 8106

Re: cannot find -lwregex // wxWidgets 2.9.2 DevPack

I have tried it again with the options below, but I receive a lot of warnings again. __WXMSW__ __GNUWIN32__ _UNICODE wxNO_RTTI -mwindows -l$(WXLIBNAME) -l$(WXLIBNAME)_gl -lwxtiff -lwxjpeg -lwxpng -lwxzlib -lwxregexu -lwxexpat -lkernel32 -luser32 -lgdi32 -lcomdlg32 -lwinspool -lwinmm -lshell32 -lcomc...
by eriX
Tue Dec 13, 2011 2:03 pm
Forum: wxDev-C++
Topic: cannot find -lwregex // wxWidgets 2.9.2 DevPack
Replies: 17
Views: 8106

Re: cannot find -lwregex // wxWidgets 2.9.2 DevPack

Great. It does work now! Maybe you can answer me 2 more questions: 1. My project can become compiled successfully, but I get a lot of warnings (see below) 2. I converted my .cpp files in UTF8 before. In standard ANSI format the compiler stops at "äöü" and says "Illegal byte sequence" - How to fix th...
by eriX
Mon Dec 12, 2011 7:28 pm
Forum: wxDev-C++
Topic: cannot find -lwregex // wxWidgets 2.9.2 DevPack
Replies: 17
Views: 8106

Re: cannot find -lwregex // wxWidgets 2.9.2 DevPack

Ok. I think we are one step further. I uninstalled wxDevC++ and deleted all caches with "TuneUp Utilities", I installed wxDevC++ "Custom mode" without downloading devpacks. Simply added my sqlite devpack, removed Objects/MingW/*.* and started compiling: -lsqlite3 -mwindows -lwxtiff -lwxjpeg -lwxpng ...
by eriX
Mon Dec 12, 2011 3:59 pm
Forum: wxDev-C++
Topic: cannot find -lwregex // wxWidgets 2.9.2 DevPack
Replies: 17
Views: 8106

Re: cannot find -lwregex // wxWidgets 2.9.2 DevPack

I tested it on my local PC... no success... same problem as before. I tried it on a XP VirtualMachine... same problem... A new project can be built without problems, but if I set any control on it... uncountable many warnings of duplicate sections... I can't see a solution to get anything working......
by eriX
Sun Dec 11, 2011 9:08 am
Forum: wxDev-C++
Topic: cannot find -lwregex // wxWidgets 2.9.2 DevPack
Replies: 17
Views: 8106

Re: cannot find -lwregex // wxWidgets 2.9.2 DevPack

Thanks for your help! I uninstalled my complete wxDevC++ I have made a complete installation of wxDevC++ 7.4 (all checkboxes are ticked) and downloaded the latest DevPacks in the setup-procedure. I have installed sqlite; wxWidgets 2.9.2 gcc; wxWidgets 2.9.2 common I have set 2.9.2 in compiler option...
by eriX
Sat Dec 10, 2011 3:42 pm
Forum: wxDev-C++
Topic: cannot find -lwregex // wxWidgets 2.9.2 DevPack
Replies: 17
Views: 8106

cannot find -lwregex // wxWidgets 2.9.2 DevPack

I need wxDevC++ with wxWidgets 2.9.2 (via DevPack!) with Unicode Support enabled. - Issue 1: After a reinstallation of wxDevC++ I always get the error: cannot find -lwregex at compiling my project. - Issue 2: For getting wxWidgets 2.9.2 I install: wxWidgets_2.9.2_common.DevPak and wxWidgets_2.9.2_gc...
by eriX
Fri Dec 09, 2011 2:50 pm
Forum: wxDev-C++
Topic: Background of wxNotebook
Replies: 20
Views: 9015

Re: Background of wxNotebook

That's describes exactly the problem.

I hope somebody has got an idea.
by eriX
Fri Dec 09, 2011 5:19 am
Forum: wxDev-C++
Topic: Background of wxNotebook
Replies: 20
Views: 9015

Re: Background of wxNotebook

7.4.0.86 doenst come with wxwidgets 2.9.2.

I have installed it and I only get errors..
Also a new project does not work, because a library is still missing.
I try to solve in about 10 hours at home.
by eriX
Thu Dec 08, 2011 3:24 pm
Forum: wxDev-C++
Topic: Background of wxNotebook
Replies: 20
Views: 9015

Re: Background of wxNotebook

Thanks for your responses! I'm using wxDevC++ 7.4.0.77 with wxWidgets 2.8.9 on Windows 7 x64. I've tried wxAuiNotebook and the normal wxNotebook in a new project but it doesn't work again. =/ @BarrRobot: Do you have success with wxWidgets 2.9.2? Does wxDevC++ 7.4.0.86 come now with wxWidgets 2.9.2 o...
by eriX
Mon Dec 05, 2011 6:32 pm
Forum: wxDev-C++
Topic: Background of wxNotebook
Replies: 20
Views: 9015

Background of wxNotebook

Hello... I can't find any way out of this problem. I want to have a black background in wxNotebook like my background is, but the colors I set become always ignored... tried it with: background-color, foreground-color, General > wxTransparentWindow... nothin works. I attached a screenshot: falsebg.p...
by eriX
Mon Oct 24, 2011 5:22 pm
Forum: C++ Development
Topic: Image-buttons with image-hover
Replies: 1
Views: 695

Image-buttons with image-hover

# Question 1: I actually work with normal buttons in my applications. But now I want to modify this app by using modern graphics. So I want to replace those ugly standard-buttons by images. The image shall change to another by hovering - and also there shall be a "hand" cursor if I am over it. How c...
by eriX
Sat Oct 01, 2011 5:34 pm
Forum: C++ Development
Topic: UTF8 text downloaded by wxHTTP is displayed wrong
Replies: 11
Views: 2652

Re: UTF8 text downloaded by wxHTTP is displayed wrong

In wxDevC++ there is an option to enable unicode-support. If I enable it, the compiler says: "cannot find -lwxmsw28u". I didn't try to compile wxWidgets by my own... maybe I'll try it in some days. If I write wxString test="äöü" and display it, it is displayed correct. Otherwise I'll replace all tho...
by eriX
Sat Oct 01, 2011 5:13 pm
Forum: C++ Development
Topic: UTF8 text downloaded by wxHTTP is displayed wrong
Replies: 11
Views: 2652

Re: UTF8 text downloaded by wxHTTP is displayed wrong

I use wxDevC++ 7.3.1.3 - Windows 7 x64
WxWidgets 2.8.9

I don't know where to look up unicode... I simply used the Installer from the Website.
by eriX
Sat Oct 01, 2011 5:03 pm
Forum: C++ Development
Topic: UTF8 text downloaded by wxHTTP is displayed wrong
Replies: 11
Views: 2652

Re: UTF8 text downloaded by wxHTTP is displayed wrong

I tested it but it didn't work.
The letters are displayed wrong.