Search found 149 matches

by jmason1182
Fri Oct 10, 2008 1:51 pm
Forum: C++ Development
Topic: unresolved reference to wxThread::TestDestroy.....
Replies: 18
Views: 2965

Nope didn't make a difference. I didn't tried building things a little different with the same options... no go.
by jmason1182
Fri Oct 10, 2008 12:55 pm
Forum: C++ Development
Topic: Can a wxComboBox have more than one style?
Replies: 4
Views: 992

You are doing it all correctly. It is just a matter of whether those options mean anything on the platform you are on.

How are you sure that it isn't firing?
by jmason1182
Fri Oct 10, 2008 12:42 pm
Forum: C++ Development
Topic: unresolved reference to wxThread::TestDestroy.....
Replies: 18
Views: 2965

When I'm doing projects for windows I always use 1 compiler, MinGW and 1 IDE - Code::Blocks. I didn't get any errors during the library compile (other than the usual warning about "attributes only being allowed during type definitions , attributes ignored" that many other people got but it's a thing...
by jmason1182
Thu Oct 09, 2008 7:58 pm
Forum: C++ Development
Topic: unresolved reference to wxThread::TestDestroy.....
Replies: 18
Views: 2965

that's funny... you redirected me to my own thread.... :D I've been working with this order of libraries for quite some time... prior to using 2.8.7. In fact, the reason why I am using this ordering is because of the issues of library dependencies. I still don't totally understand how if I use the b...
by jmason1182
Thu Oct 09, 2008 3:23 pm
Forum: C++ Development
Topic: what is a non-virtual thunk? (wxChoice::GetCount, etc.)
Replies: 2
Views: 2475

Here's the most helpful quote I've found so far: (from http://lists.apple.com/archives/xcode-users/2006/Dec/msg00339.html) > > Trying to compile project and linking my library I see several link > errors "undefined symbol: undefined non-virtual thunk to > Class::Member()". All members are from libra...
by jmason1182
Thu Oct 09, 2008 3:20 pm
Forum: C++ Development
Topic: unresolved reference to wxThread::TestDestroy.....
Replies: 18
Views: 2965

(Secret note: Cool! I've finally hit 100 posts on this forum!) Ok, I completely deleted the entire directory structure of my project, then rebuilt the project from scratch. Still no go. However, I now have a different "source" of the issue.... WindowBase.GetClientSize.... Some things have changed.....
by jmason1182
Thu Oct 09, 2008 3:07 pm
Forum: C++ Development
Topic: unresolved reference to wxThread::TestDestroy.....
Replies: 18
Views: 2965

Yes, the samples compile. (see below for my build of the combo example) -------------- Build: Win32 Debug in combo --------------- [ 33.3%] windres.exe -i C:\wx\WXWIDG~1.9\samples\sample.rc -J rc -o gcc_mswd\combo\samples\sample.res -O coff -I.\..\..\lib\gcc_lib\mswd -I.\..\..\include -I. -I.\..\..\...
by jmason1182
Wed Oct 08, 2008 6:28 pm
Forum: C++ Development
Topic: unresolved reference to wxThread::TestDestroy.....
Replies: 18
Views: 2965

Well let's take my program out of the question... it builds perfectly. The linking is the problem, so that is where I think the problem lies.

I think I don't have my library build done exactly what I need. Can anyone make a suggestion as to what to try to rebuild the library so I can use it?
by jmason1182
Mon Oct 06, 2008 8:18 pm
Forum: C++ Development
Topic: unresolved reference to wxThread::TestDestroy.....
Replies: 18
Views: 2965

Yes, these are unmodified 2.8.9 sources. (completely separated path from 2.8.7. Code::BLocks makes it easy... change the environment variable to the wx path and viola it changes where it looks for wxWidgets since I have my project built around the environment variable... I digress) I'll remove the m...
by jmason1182
Mon Oct 06, 2008 3:01 pm
Forum: Compiler / Linking / IDE Related
Topic: Unresolved external Symbol
Replies: 3
Views: 2485

I have the same type of errors, and I checked and I don't have a BEGIN_EVENT_TABLE/END_EVENT_TABLE without the DECLARE_EVENT_TABLE

Any other suggestions?
by jmason1182
Mon Oct 06, 2008 2:54 pm
Forum: C++ Development
Topic: "The application failed to initialize properly(0xc00000
Replies: 3
Views: 950

I'm receiving the same errors when I do my Debug DLL build. I was getting all sorts of rediculous errors when my project had WXUSINGDLL defined... so I removed it. Now I am getting this error.

Any suggestions? Any trains of thoughts.
by jmason1182
Mon Oct 06, 2008 2:39 pm
Forum: C++ Development
Topic: unresolved reference to wxThread::TestDestroy.....
Replies: 18
Views: 2965

Since I have to get my project moving forward again I am going to "roll-back" to use wxWidgets 2.8.7 (since i'm using Code::Blocks, this is really easy! just change the global variable and viola!) I will however, want an answer so I'll keep some form of the 2.8.9 version compilable to see if I can g...
by jmason1182
Mon Oct 06, 2008 1:19 pm
Forum: C++ Development
Topic: what is a non-virtual thunk? (wxChoice::GetCount, etc.)
Replies: 2
Views: 2475

what is a non-virtual thunk? (wxChoice::GetCount, etc.)

Anybody have any idea what this kind of error means? I'm trying to upgrade from 2.8.7 to 2.8.9 and apparently something isn't compatible. obj\Debug\wx\treelistctrl\treelistctrl.o: In function `ZN25wxArrayTreeListColumnInfo7DoEmptyEv': J:/JACII_CB/JACII/wx/treelistctrl/treelistctrl.cpp:809: undefined...
by jmason1182
Mon Oct 06, 2008 1:15 pm
Forum: C++ Development
Topic: unresolved reference to wxThread::TestDestroy.....
Replies: 18
Views: 2965

unresolved reference to wxThread::TestDestroy.....

I had a fully working project until I upgraded to 2.8.9. Wasn't a big deal, I went from wxPack (2.8.7) to just the straight 2.8.9 release. I built the library just fine, and can fine-tune it. I've already dealt with setup.h not matching my build options.... but now I can't get it to compile because ...
by jmason1182
Fri Oct 03, 2008 7:54 pm
Forum: Compiler / Linking / IDE Related
Topic: unresolved reference to wxThread::TestDestroy.....
Replies: 0
Views: 443

unresolved reference to wxThread::TestDestroy.....

I had a fully working project until I upgraded to 2.8.9. Wasn't a big deal, I went from wxPack to just the straight 2.8.9 release. I build the library just fine, and can fine-tune it. I've already dealt with setup.h not matching my build options.... but now I can't get it to compile because of some ...